cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Mehta <>
Subject Re: Storage Allocation Error
Date Sat, 01 Dec 2012 07:19:27 GMT
Nik - both the explanation do not seem completely coherent to me. Can you please try this again
and paste the snippet of logs with the issue (grep for job id like here "job-110") ?
Make sure you are using a disk offering with shared storage type for creating your data disk

On 01-Dec-2012, at 4:46 AM, Nik Martin wrote:

> On 11/30/2012 05:11 PM, Nik Martin wrote:
>> I created a VM from an ISO, then shutdown the VM, detached the iso, 
>> then tried to add anew volume to the VM.  When I attached the volume, 
>> I got an error:
>> 2012-11-30 17:08:34,069 INFO  [cloud.api.ApiDispatcher] 
>> (Job-Executor-10:job-110) Please specify a volume that has been 
>> created on a shared storage pool.
>> The volume was created on shared storage, so I'm not sure what's 
>> wrong. Cloudstack is version 3.02, storage is iSCSI, Hypervisors are 
>> Xenserver 6.02
>> Regards,
>> Nik
> More information, it appears that the Volume was in state "Allocated" 
> when I tried to attach it.  It stayed in that state for what seems like 
> too long.  It then transitioned to "Creating", and stayed in that state 
> an unusually long time.  The Allocated state persisted for about 5-7 
> minutes, and the Creating State for 10.  It is a 100 Gb volume on an 
> iSCSI SAN that is very fast.
> The only error was the one mention in my original message.

View raw message