cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nik Martin <>
Subject Re: Storage Allocation Error
Date Sun, 02 Dec 2012 15:27:42 GMT
On 12/01/2012 01:19 AM, Nitin Mehta wrote:
> Nik - both the explanation do not seem completely coherent to me. Can you please try
this again and paste the snippet of logs with the issue (grep for job id like here "job-110")
> Make sure you are using a disk offering with shared storage type for creating your data
This appears to be something on the management server.  This i a brand 
new re-install of cloudstack on the management server.  The storage 
volume was made up of mostly NULL columns in the storage_volumes table. 
  I deleted it from the table directory.  It seems that frequently 
commands are failing the first time, and if I re-run it, it works.  I 
just tried to create a VM from an ISO, and it failed with this error:

2012-12-02 09:16:58,658 INFO  [api.commands.DeployVMCmd] 
(Job-Executor-6:job-135) Unable to 
create a deployment for VM[User|i-2-25-VM]Scope=interface; id=1
2012-12-02 09:16:58,659 WARN  [cloud.api.ApiDispatcher] 
(Job-Executor-6:job-135) class : Unable 
to create a deployment for VM[User|i-2-25-VM]

But I ran it again, and it ran fine.  Is there something I should check? 
  I have plently of server capacity in every respect: disk, cpu, ram.


> On 01-Dec-2012, at 4:46 AM, Nik Martin wrote:
>> On 11/30/2012 05:11 PM, Nik Martin wrote:
>>> I created a VM from an ISO, then shutdown the VM, detached the iso,
>>> then tried to add anew volume to the VM.  When I attached the volume,
>>> I got an error:
>>> 2012-11-30 17:08:34,069 INFO  [cloud.api.ApiDispatcher]
>>> (Job-Executor-10:job-110) Please specify a volume that has been
>>> created on a shared storage pool.
>>> The volume was created on shared storage, so I'm not sure what's
>>> wrong. Cloudstack is version 3.02, storage is iSCSI, Hypervisors are
>>> Xenserver 6.02
>>> Regards,
>>> Nik
>> More information, it appears that the Volume was in state "Allocated"
>> when I tried to attach it.  It stayed in that state for what seems like
>> too long.  It then transitioned to "Creating", and stayed in that state
>> an unusually long time.  The Allocated state persisted for about 5-7
>> minutes, and the Creating State for 10.  It is a 100 Gb volume on an
>> iSCSI SAN that is very fast.
>> The only error was the one mention in my original message.

View raw message