cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Ottonello <>
Subject Re: Getting CRAZY for having a cloud working!
Date Wed, 19 Dec 2012 13:52:11 GMT
Hi Marc.
This is basically my config:
- 1 XCP 1.5 beta host, with 2 quad core CPU, 22 GB of RAM 2 NICs (1
dedicated to management, 1 to VMs), 2 Qlogic HBAs. It's IP is,
his name is manually configured like A record in my work domain DNS and is
correctly resolved. It is attached via fiber to a storage and has a 200 GB
LUN assigned for primary storage purposes.
- 1 Ubuntu Server 12.04 virtual running on an Hyper-V host, with one NIC,
IP address On it I installed Cloudstack 4.0.0 and MySql. In
my many attempts, I installed it also with NFS shares but since
Installation instructions are not correct for Ubuntu (for example, a folder
/ect/sysconfig does not exists on it) and seeing issues with SS, I finally
installed a...
- 1 CentOS 6.3 configured minimal with NFS shares /export/secondary. IP I tested connecting to its shares and it works. I also tried
to create/delete files inside share and worked.
- My client, a Windows 7 notebook on which I installed XenCenter to manage
my host.
All machine names are registered in DNS, names are correctly resolved by
all machines. They are all fresh installs, updated to last patches
available via yum/apt-get.
Here is a piece of management-log, I can send it zipped if you like.

464 DEBUG [allocator.impl.FirstFitAllocator]
(consoleproxy-1:FirstFitRoutingAllocator) Host name: ITGOAZ1P1C1H1, hostId:
1 is in avoid set, skipping this and trying other available hosts
2012-12-19 09:21:45,464 DEBUG [allocator.impl.FirstFitAllocator]
(consoleproxy-1:FirstFitRoutingAllocator) Host Allocator returning 0
suitable hosts
2012-12-19 09:21:45,464 DEBUG [cloud.deploy.FirstFitPlanner]
(consoleproxy-1:null) No suitable hosts found
2012-12-19 09:21:45,464 DEBUG [cloud.deploy.FirstFitPlanner]
(consoleproxy-1:null) No suitable hosts found under this Cluster: 1
2012-12-19 09:21:45,464 DEBUG [cloud.deploy.FirstFitPlanner]
(consoleproxy-1:null) Could not find suitable Deployment Destination for
this VM under any clusters, returning.
2012-12-19 09:21:45,474 DEBUG [cloud.capacity.CapacityManagerImpl]
(consoleproxy-1:null) VM state transitted from :Starting to Stopped with
event: OperationFailedvm's original host id: null new host id: null host id
before state transition: 1
2012-12-19 09:21:45,479 DEBUG [cloud.capacity.CapacityManagerImpl]
(consoleproxy-1:null) Hosts's actual total CPU: 12760 and CPU after
applying overprovisioning: 12760
2012-12-19 09:21:45,479 DEBUG [cloud.capacity.CapacityManagerImpl]
(consoleproxy-1:null) release cpu from host: 1, old used: 500,reserved: 0,
actual total: 12760, total with overprovisioning: 12760; new used:
0,reserved:0; movedfromreserved: false,moveToReserveredfalse
2012-12-19 09:21:45,479 DEBUG [cloud.capacity.CapacityManagerImpl]
(consoleproxy-1:null) release mem from host: 1, old used:
1073741824,reserved: 0, total: 20084424192; new used: 0,reserved:0;
movedfromreserved: false,moveToReserveredfalse
2012-12-19 09:21:45,485 WARN  [cloud.consoleproxy.ConsoleProxyManagerImpl]
(consoleproxy-1:null) Exception while trying to start console proxy Unable to create a
deployment for VM[ConsoleProxy|v-2-VM]Scope=interface; id=1

2012/12/19 Marc Cirauqui <>

> hi Andrea,
> I've seen some of your mails, can you post some logs and config? I know
> you've been posting recently, it's just tu sum up here...
> thx
> On Wed, Dec 19, 2012 at 1:22 PM, Andrea Ottonello <
> >wrote:
> > Hallo all.
> > I'm just trying to setup this "turnkey" (??????) solution up and running
> > with very STANDARD config, but I obtain NOTHING at all.
> > Scenario:
> > - a fresh installed host running XCP 1.5 beta, added to a pool using
> > XenCenter and with a primary storage configured and recognized, I can
> > install a VM on it successfully using XenCenter.
> > - a virtual machine running Ubuntu Server 12.04 fresh install, on another
> > hypervisor (Hyper-V), working normally, updated, able to resolve DNS and
> > reach Internet. On the network there are 2 DNS servers working (my
> Windows
> > domain's DNS). I want to use it as management/mysql machine for
> Cloudstack
> > 4.0.0
> > - another virtual machine with a fresh installation of CentOS for NFS
> > server activated to have secondary storage on different server, it is
> > working and I can mount its shares on management and host machines.
> >
> > Ok, I followed installation guide STEP-BY-STEP, everything seems to be
> ok,
> > template downloaded, I can login to WebUI. But I cannot get a Zone
> working.
> > I tried with startup wizard, I tried (reinstalling from scratch about 12
> > times) from standard UI adding first zone... NOTHING. System machines not
> > starting. Trying to recreate SSVM in a loop, CPVM stuck in Starting
> state.
> > I searched EVERYTHING. In management log, it says that cannot find a host
> > on which to put VM, because my host is in AVOID SET...
> > The host has 22 GB of RAM, 2 QUAD CORE CPU, and anyway is working
> because I
> > can put on it a VM using XenCenter without ANY issue.
> > I have wasted 2 weeks trying to get it SIMPLY running, I'm going to give
> up
> > and search for another solution (Openstack maybe?)
> > But any help would be appreciated.
> >
> > Best regards
> > --
> > Andrea Ottonello
> >

Andrea Ottonello

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message