cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ram kumar <ram.kumar.linux1...@gmail.com>
Subject problem in key generation and in adding the host
Date Mon, 03 Jun 2013 11:44:20 GMT
Hi All,

I am new to cloudstack and trying to configure it on Ubuntu 12.04 with
Cloudstack 1:4.0.2. My tomcat version is 6.0.35. I am facing following
problem during the key generation and adding the host. When I tried to
generate the key I got following values:

curl --globoff "
http://localhost:8096/?command=createSSHKeyPair&name=keypair-doc&account=admin&domainid=a883af06-d6c6-4427-b5bf-c88154b46e28
"
<?xml version="1.0" encoding="UTF-8"?><createsshkeypairresponse
cloud-stack-version="4.0.2.20130501180711"><keypair><name>keypair-doc</name><fingerprint>9a:ae:3f:9c:6e:eb:4a:bb:4a:fb:75:9d:1e:60:f5:f8</fingerprint></keypair></createsshkeypairresponse>root@kri0RP:/var/log/cloud#


But I didn't get any private key on the console. I tried to search
keypair-doc file but I didn't get it. Can anyone help me here to get the
key ? If I am trying to run the same command it is telling that key has
already generated in keypair-doc. Can I regenerate the key with other
domain id and what is the command to get other domain id ?

When I tried to add the host I am not able to add the host in a cluster. Is
it due to SSH-key generation problem ? I have checked individual SSH login,
PORT status  and PING of host. Everything seems fine to me. Please tell me
which log I should refer to further debug this.

Is there any global setting available by which I can bypass all the key
related authentication and I should be able to add the host ?

Please help me on above points.

Best Regards,
Ram

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message