cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From murali reddy <muralimmre...@gmail.com>
Subject Re: cloudstack 4.1 GRE/SDN
Date Thu, 03 Oct 2013 05:40:14 GMT
Have you tried to create a new isolated network for the VM after setting
'sdn.ovs.controller' to  true? Please see
https://issues.apache.org/jira/browse/CLOUDSTACK-2878


On Thu, Oct 3, 2013 at 9:11 AM, Luca Salvatore <Luca@ninefold.com> wrote:

> i'm trying to do some testing with cloudstack 4.1, specifically around the
> GRE and SDN features.
> I have configured the management server and I have two zones.  Everything
> is working well, I can deploy VMs in each zone and everything there is
> good. Each zone is configured with GRE isolation.
> When I changed the sdn.ovs.controller to true and tried to deploy VMs they
> all failed, weird thing is that they don't even appear in the management
> console in a error state, just nothing happens.  The logs do show an
> exception:
>
>
> 2013-10-03 11:48:47,171 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> (catalina-exec-20:null) Allocating entries for VM: VM[User|test1]
> 2013-10-03 11:48:47,172 DEBUG [cloud.vm.VirtualMachineManagerImpl]
> (catalina-exec-20:null) Allocating nics for VM[User|test1]
> 2013-10-03 11:48:47,173 DEBUG [cloud.network.NetworkManagerImpl]
> (catalina-exec-20:null) Allocating nic for vm VM[User|test1] in network
> Ntwk[208|Guest|8] with requested profile NicProfile[0-0-null-null-null
> 2013-10-03 11:48:47,179 DEBUG [db.Transaction.Transaction]
> (catalina-exec-20:null) Rolling back the transaction: Time = 22 Name =
>  createVirtualMachine; called by
> -Transaction.rollback:890-Transaction.removeUpTo:833-Transaction.close:657-TransactionContextBuilder.interceptException:63-ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept:133-VirtualMachineManagerImpl.allocate:304-ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept:125-CloudOrchestrator.createVirtualMachine:211-UserVmManagerImpl.createVirtualMachine:3384-ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept:125-UserVmManagerImpl.createAdvancedVirtualMachine:3101-DeployVMCmd.create:460
> 2013-10-03 11:48:47,189 ERROR [cloud.api.ApiServer]
> (catalina-exec-20:null) unhandled exception executing api command:
> deployVirtualMachine
> java.lang.NullPointerException
>         at
> com.cloud.network.NetworkManagerImpl.allocateNic(NetworkManagerImpl.java:1267)
>         at
> com.cloud.utils.component.ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept(ComponentInstantiationPostProcessor.java:125)
>         at
> com.cloud.network.NetworkManagerImpl.allocate(NetworkManagerImpl.java:1206)
>         at
> com.cloud.utils.component.ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept(ComponentInstantiationPostProcessor.java:125)
>         at
> com.cloud.vm.VirtualMachineManagerImpl.allocate(VirtualMachineManagerImpl.java:304)
>         at
> com.cloud.utils.component.ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept(ComponentInstantiationPostProcessor.java:125)
>
>
> Not sure what is going on here.  Any thoughts?
> I'm using XenSever 6.1 with a single bond (2 NICs) for all networks, also
> using local storage for all VMs.
> Can't seem to find much doco on how to configure zones for SDN… Any help
> would be great
>
> Thanks
> Luca.
>
>
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message