cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Phillips <>
Subject RE: Build Failure SNMP Alerts‏
Date Wed, 19 Feb 2014 00:04:30 GMT
Yes, the test that is failing is the "Apache Cloudstack Plugin - SNMP Alerts"
Surely someone has run into this problem before...

> Date: Tue, 18 Feb 2014 15:48:19 -0500
> From:
> To:
> Subject: Re: Build Failure SNMP Alerts‏
> Deleting repos to fix test failures is certainly a longshot.
> It appears that Maven built your code and was trying to test it.
> Did you look in the test logs to see which test failed and why. Could be 
> a configuration/initialization issue rather than code (points to an IP 
> that makes no sense, uses a database that does not exist or is empty, etc)
> If you feel brave or you think that the test can not suceed in your 
> environment , you can ask maven to skip the tests and just test it in 
> your setup.
> If you delete your repo, you will have to rebuild any modules that you 
> built before. You have deleted whatever libraries and utilities that you 
> built in previous steps.
> Ron
> On 18/02/2014 3:33 PM, Michael Phillips wrote:
> >
> >
> > All,
> > I have been experiencing a build failure, trying to build nonoss RPMS for ver 4.2.1.
The error I get is on the SNMP alerts plugin. The exact error message is "failed to execute
goal org.apache.maven.plugins:maven-surefire-plugin:2.12:test (default-test) on project cloud-plugin-snmp-alerts:
There are test failures."
> > I searched this on the mailing lists and found one other user who was having the
exact same problem and it looks like he fixed it by deleting the repo at the following location
~/.m2/repository/. When I delete the ~/.m2/repository/ directory, I then get an error when
building, when it gets to the VMware Base plugin. My guess is that by deleting the repo, I
am deleting Vmware files it needs to build successfully. Users also suggested making sure
I am using the correct version of maven. I have tried using version 3.1.0 and 3.0.4 both end
with the same error.
> > Any suggestions?
> >   		 	   		
> -- 
> Ron Wheeler
> President
> Artifact Software Inc
> email:
> skype: ronaldmwheeler
> phone: 866-970-2435, ext 102
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message