cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Phillips <mphilli7...@hotmail.com>
Subject Build Failure SNMP Alerts‏
Date Tue, 18 Feb 2014 20:33:43 GMT



All,
I have been experiencing a build failure, trying to build nonoss RPMS for ver 4.2.1. The error
I get is on the SNMP alerts plugin. The exact error message is "failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12:test
(default-test) on project cloud-plugin-snmp-alerts: There are test failures."
I searched this on the mailing lists and found one other user who was having the exact same
problem and it looks like he fixed it by deleting the repo at the following location ~/.m2/repository/.
When I delete the ~/.m2/repository/ directory, I then get an error when building, when it
gets to the VMware Base plugin. My guess is that by deleting the repo, I am deleting Vmware
files it needs to build successfully. Users also suggested making sure I am using the correct
version of maven. I have tried using version 3.1.0 and 3.0.4 both end with the same error.

Any suggestions?
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message