cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Reategui <car...@reategui.com>
Subject Re: basic zone setup
Date Thu, 31 Jul 2014 01:09:39 GMT
There have been some messages going around about the template needing a fix
for this.

Per this link (https://gist.github.com/terbolous/102ae8edd1cda192561c) from
one of the messages you can try the following on the ssvm itself:

apt-get update && apt-get -y install openjdk-7-jre-headless
openjdk-7-jre-lib && apt-get -y remove openjdk-6-jre-headless

then you may also need to:
service cloud stop && sleep 3 && service cloud start

try the ssvm-check again after that.

My understanding is that this is not a permanent fix, but should get you
going for now.


On Wed, Jul 30, 2014 at 6:00 PM, Ian Young <iyoung@ratespecial.com> wrote:

> I found this in the cloud.out log in the SSVM:
>
> Exception in thread "main" java.lang.UnsupportedClassVersionError:
> com/cloud/agent/AgentShell : Unsupported major.minor version 51.0
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
> at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
> at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
> at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> Could not find the main class: com.cloud.agent.AgentShell. Program will
> exit.
>
> It seems to have to do with a Java version mismatch.  I'm using JDK 7 on
> both the management server and hypervisor but the SSVM is using version 6.
>  Is this the most current system VM template?
>
>
> http://download.cloud.com/templates/4.3/systemvm64template-2014-01-14-master-kvm.qcow2.bz2
>
>
> On Wed, Jul 30, 2014 at 5:25 PM, Ian Young <iyoung@ratespecial.com> wrote:
>
> > root@s-2-VM:~# /usr/local/cloud/systemvm/ssvm-check.sh
> > ================================================
> > First DNS server is  192.168.100.2
> > PING 192.168.100.2 (192.168.100.2): 48 data bytes
> > 56 bytes from 192.168.100.2: icmp_seq=0 ttl=64 time=1.227 ms
> > 56 bytes from 192.168.100.2: icmp_seq=1 ttl=64 time=0.882 ms
> > --- 192.168.100.2 ping statistics ---
> > 2 packets transmitted, 2 packets received, 0% packet loss
> > round-trip min/avg/max/stddev = 0.882/1.054/1.227/0.173 ms
> > Good: Can ping DNS server
> > ================================================
> > Good: DNS resolves download.cloud.com
> > ================================================
> > ERROR: NFS is not currently mounted
> > Try manually mounting from inside the VM
> > NFS server is  169.254.1.0
> > PING 169.254.1.0 (169.254.1.0): 48 data bytes
> > 56 bytes from 169.254.1.0: icmp_seq=0 ttl=64 time=0.067 ms
> > 56 bytes from 169.254.1.0: icmp_seq=1 ttl=64 time=0.039 ms
> > --- 169.254.1.0 ping statistics ---
> > 2 packets transmitted, 2 packets received, 0% packet loss
> > round-trip min/avg/max/stddev = 0.039/0.053/0.067/0.000 ms
> > Good: Can ping nfs server
> > ================================================
> > Management server is 192.168.101.3. Checking connectivity.
> > Good: Can connect to management server port 8250
> > ================================================
> > ERROR: Java process not running.  Try restarting the SSVM.
> >
> > It says the NFS server is 169.254.1.0 which is the SSVM's link local
> > address.  How did it decide that?  During the zone configuration I
> > specified "virthost1.lax.ratespecial.com" as the NFS server and that
> > resolves to 192.168.101.4.  Also, in what path does it expect the NFS
> > volume to be mounted?
> >
> >
> > On Wed, Jul 30, 2014 at 4:53 PM, Carlos Reategui <carlos@reategui.com>
> > wrote:
> >
> >> If the template is not ready then your ssvm may be having problems
> >> downloading it.  Have you followed the info here:
> >>
> >>
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/SSVM,+templates,+Secondary+storage+troubleshooting
> >> to make sure that the ssvm is actually working properly?
> >>
> >>
> >> On Wed, Jul 30, 2014 at 4:39 PM, Ian Young <iyoung@ratespecial.com>
> >> wrote:
> >>
> >> > I've reinstalled CloudStack 4.4 again, configuring the network as
> >> follows:
> >> >
> >> > management server:
> >> > p4p1 http://pastebin.com/skMXxVtk
> >> >
> >> > hypervisor/storage server:
> >> > eth0 http://pastebin.com/LxUxFdpe
> >> > eth1 http://pastebin.com/K5si1L4d
> >> > cloudbr0 http://pastebin.com/heZGQfVs (management/storage traffic)
> >> > cloudbr1 http://pastebin.com/nprB2Kx7 (guest traffic)
> >> >
> >> > When I logged into the management GUI for the first time, I skipped
> the
> >> > wizard and went straight to the dashboard.  There, I set up a basic
> >> zone as
> >> > follows:
> >> >
> >> > http://imgur.com/a/R1dX0#0
> >> >
> >> > Now that the infrastructure has been launched and the SSVM and console
> >> > proxy are running, I noticed that the CentOS template is not ready.
> >> >  Neither the management server or the hypervisor are downloading
> >> anything,
> >> > so it doesn't appear the CentOS template will be ready.  If I try to
> >> > register my own templates, I fill out all the fields but the window
> just
> >> > disappears when I click OK and no template is added.  I don't see any
> >> new
> >> > messages in the management server log at the time this occurs.  I
> >> suspect
> >> > there is a storage problem.  However, I can mount the NFS shares onto
> >> the
> >> > management server with no problems.  That's how I was able to manually
> >> > download the system VM template, as the installation guide indicated.
> >> >  What's wrong with this setup?  I don't see any obvious errors in the
> >> > management log besides these repetitive messages, which seem to
> >> contradict
> >> > the fact that there is a SSVM and console proxy running:
> >> >
> >> > http://pastebin.com/yvW5GmSB
> >> >
> >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message