cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilya <ilya.mailing.li...@gmail.com>
Subject Re: Problem with VolumeMigration, stuck after first migration‏
Date Tue, 13 Oct 2015 20:58:52 GMT
Hi Emil,

I believe there are some restrictions on how migration is handled with
vmware.

Please explain from resource standpoint what you are running and how
test is made..

i.e. how many hosts and datastores in your cluster and how tests are made..

Example:
Test 1 Source: vm1, host 1, datastore1
Test 1 Dest: vm1, host 1, datastore2

Test 2 Source: vm1, host 2, datastore3
Test 2 Dest: vm1, host 2, datastore4



When you try to migrate, see of you can migrate vms that are on
different host and datastore - but in the same cluster...

I vaguely recall there was a limit of concurrent operations on single
object...

Regards
ilya


On 10/11/15 1:17 PM, Emil wrote:
> Hello dear users,
> we implemented cloudstack (4.5.2) in a private network, as hypervisor we
> used VmWare (ESXi 5.5).
> 
> The enviornment running perfectly except for one strange and annoying
> problem.
> When we are trying the migrate a volume it migrates very fine and we can
> see it the vSphere Client,
> 
> but !! when we are trying to make another migration it just enter the queue
> (can see it with listAsyncJobs)
> and it waits for the first migration to end, when the first migration ends
> the second migration starting
> Not only the second migration not running parallel or any third, fourth ...
> ,
> Any task we are trying to run enters the queue (deploy, snapshot, anything)
> !
> 
> We are tried to run every thing from the api, same results,
> searched the logs for warning, but every thing seems to be OK,
> it even wrote "job-165 entered for monitoring" (Sorry if it ain't accurate)
> for the second migration or
> any other task we are trying to execute
> 
> I must admit that when we are trying to run anything else then migration,
> it runs parallel (Taking Snapshots, Deployments)
> 
> When I looked at the list of AsyncJobs (through the api), the jobstatus of
> the new tasks (When first migration deployed) it valued as 0.
> 
> Why it is stuck ? and not running parallel ? Can someone help here ?
> 

Mime
View raw message