cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emil <>
Subject Volume migration not working in asynchronous way | Urgent help !
Date Tue, 13 Oct 2015 19:07:58 GMT

We have a big problem in our environment which not letting us keep working.
We are trying to use the command migrateVolume which is written as
asynchronous in cloudstack API.

But in some way every time we try to run the command (through the API or
only 1x migration running at a time (At very very rare situations 2x
migrations running simultaneously).

I tried to check every configuration settings especially those:


They were defaulted as false, I tried them with true as value also didnt

Also if we are trying to run storage vMotion through the vSphere client, it
working great (3,4,5 simultaneously)

Some details about our environment:

vSphere 5.5
CS 4.5.2

Some logs conclusions:

When preforming the first volumeMigration it seems like each task has a
sequence id, which registerd some where,
then the task "Executing" it self and every thing fine. Got unique job id
 for the task (to trace the status).

When the second volumeMigration executed there is a line in the log which
very suspicious and it says:
"Waiting for Seq 244522346426 Scheduling: .."
That sequence id is the id of the first migration ! Why the hell he waiting
for the first task ?!

I hope some one will see ot and can help. Very urgent case.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message