cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Sender" <>
Subject Re: Unable to Start VM SR failure
Date Mon, 17 Jul 2017 00:56:07 GMT

Hi Jeremy,

You need to find the uuid of the vdi, I couldn't find it in the logs.

The “VDI Not Available” error appears when a virtual machine (VM) is shutdown
inappropriately or if there is a concern with the Storage Repository (SR)
where the virtual machine exists

There are a number of logs that differ slightly but all relate to the problem
of the VDI locked.

Steps to fix the issue :

When a VM is started on a XenServer host, domain 0, needs to ensure that all
resources required by the guest VM are available for it to start. If a VM has
had an unexpected shutdown, power failure, etc., we could have a dirty flag on
the VDI, which is normally a logical volume in a volume group (Storage
Repository). To clear this flag, we need to do the following actions:

1. Via the command line, type “xe vm-start vm=<name of VM>” and you will get a
better error message than noted in the XenCenter, namely the UUID of the VDI
that cannot be used exclusively by the guest VM.
2. Make a note of the UUID of the VDI and proceed to remove it from the pool
database via the following “xe vdi-forget uuid=<UUID of the VDI>. You will
then note that the VM no longer is attached to the VDI in XenCenter.
3. On the SR that the VDI is located on, proceed to the “Storage” tab and
select “Rescan”. You should see the VDI with no name label on it.
4. To ensure we have the correct VDI, if there are many VDIs with no name, use
the following command “xe vdi-list uuid=<UUID of the VDI>. You should see it
with no name label or description. We can then label this VDI via “xe
vdi-param-set uuid=<UUID of the VDI> name-label=<New name label>”. You should
see the labeled VDI in the XenCenter.
5. On the VMs storage tab, select “Attach” and proceed to select the VDI on
the SR.
6. VM should start without issue.

Example: On Pool Master

[root@tl01 ~]# xe vdi-list uuid=741ef409-2c15-43f3-a10e-50f1467ee668
uuid ( RO) : 741ef409-2c15-43f3-a10e-50f1467ee668
name-label ( RW): cloud-df8bdcdc-ff00-43cd-a6a4-e79ccd6cd8a1
name-description ( RW):
sr-uuid ( RO): dc0e0a15-a520-9861-edb2-a808fb095df5
virtual-size ( RO): 10737418240
sharable ( RO): false
read-only ( RO): false

[root@tl01 ~]# xe vdi-forget uuid=741ef409-2c15-43f3-a10e-50f1467ee668
[root@tl01 ~]# xe sr-scan uuid=dc0e0a15-a520-9861-edb2-a808fb095df5
[root@tl01 ~]# xe vdi-param-set uuid=741ef409-2c15-43f3-a10e-50f1467ee668

Adrian Sender

---------- Original Message -----------
From: Jeremy Peterson <>
To: "" <>
Sent: Thu, 13 Jul 2017 21:26:21 +0000
Subject: Unable to Start VM SR failure

> Ok so I am back at the users again.
> I had 1 VM lock up today and was forced to issue a restart as the OS 
> was non responsive.
> After powering off the VM bounced around between hosts and 
> ultimately stopped and failed with an insufficient resources error.
> I looked around in XenServer and found the ROOT volume on one of the 
> SCSI LUNS's 100GB great.
> I tried to download the volume in CS failed. I tried to create 
> template from volume failed.
> Went to start the Volume again and this is the error log.
> What is jumping out at me is
> errorInfo: [SR_BACKEND_FAILURE, non-zero exit, , Traceback (most 
> recent call last):
> After that error I get a ton of /opt/xensource/sm  failure messages.
> 1.  2017-07-13 16:01:59,983 WARN  [c.c.h.x.r.CitrixResourceBase] 
> (DirectAgent-380:ctx-0f865755) Unable to clean up VBD due to
> 2.  You gave an invalid object reference.  The object may have 
> recently been deleted.  The class parameter gives the type of 
> reference given, and the handle parameter echoes the bad value given.
> You can see ROOT-277 is on my storage.
> The "dev" server has the Volumes of ROOT-277
> Ideas ?
> Jeremy
------- End of Original Message -------

View raw message