cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Melanie Desaive <m.desa...@heinlein-support.de>
Subject Re: SystemVM Storage Tags not taken into account?
Date Fri, 01 Nov 2019 08:33:08 GMT
Good morning Andrija,

yes, I did restart mgmt. Documentation states that.

Interestingly the documentation in 
http://docs.cloudstack.apache.org/en/4.11.1.0/adminguide/service_offerings.html#changing-the-default-system-offering-for-system-vms
only mentions only resetting the unique_names for Secondary Storage VM
and Console Proxy VM not for the Virtual Routers in the database.

Maybe the procedure for resetting the System Offering for Virtual
Routers differs from that for SSVM and CP and I missed some point?

Greetings,

Melanie

Am Donnerstag, den 31.10.2019, 17:19 +0100 schrieb Andrija Panic:
> tried restarting mgmt after tag change? Usually not required but
> might be
> for systemVMs.
> 
> On Thu, 31 Oct 2019, 15:21 Melanie Desaive, <m.desaive@mailbox.org>
> wrote:
> 
> > Hi all,
> > 
> > I just tried to set up storage tags for System VMs, but the
> > behaviour
> > is not as expected. The deployment planner does not seem to take
> > the
> > storage tag into account when deciding over the storage.
> > 
> > --
> > 
> > The only storage with the tag "SYSTEMV" ist "ACS-LUN-SAS-01' with
> > id=10
> > 
> > mysql> select id,name,tag from storage_pool_view where cluster_name
> > =
> > 'cluster2' and status = 'Up' and tag = 'SYSTEMVM' order by
> > name,tag;
> > +----+----------------+----------+
> > > id | name           | tag      |
> > +----+----------------+----------+
> > > 10 | ACS-LUN-SAS-01 | SYSTEMVM |
> > +----+----------------+----------+
> > 1 row in set (0,00 sec)
> > 
> > --
> > 
> > I definied the tag "SYSTEVM" for the System Offering for the
> > Virtual
> > Routers:
> > 
> > mysql> select id,name,unique_name,type,state,tags from
> > disk_offering
> > where type='Service' and state='Active' and unique_name like
> > 'Cloud.Com-SoftwareRouter' order by unique_name \G
> > *************************** 1. row ***************************
> >          id: 281
> >        name: System Offering For Software Router - With Tags
> > unique_name: Cloud.Com-SoftwareRouter
> >        type: Service
> >       state: Active
> >        tags: SYSTEMVM
> > 1 row in set (0,00 sec)
> > 
> > --
> > 
> > But when I redeploy a virtual Router the deployment planner takes
> > all
> > storages into account. :(
> > 
> > The log saies explicitely "Pools matching tags..." and lists
> > several
> > other pools.
> > What do I miss?
> > 
> > --
> > ClusterScopeStoragePoolAllocator looking for storage pool
> > Looking for pools in dc: 1  pod:1  cluster:3. Disabled pools will
> > be
> > ignored.
> > Found pools matching tags: [Pool[7|PreSetup], Pool[9|PreSetup],
> > Pool[10|PreSetup], Pool[18|PreSetup]]
> > ClusterScopeStoragePoolAllocator returning 3 suitable storage pools
> > ClusterScopeStoragePoolAllocator looking for storage pool
> > Looking for pools in dc: 1  pod:1  cluster:3. Disabled pools will
> > be
> > ignored.
> > Found pools matching tags: [Pool[7|PreSetup], Pool[9|PreSetup],
> > Pool[10|PreSetup], Pool[18|PreSetup]]
> > ClusterScopeStoragePoolAllocator returning 3 suitable storage pools
> > --
> > 
> > Kind regards,
> > 
> > Melanie
> > 


Mime
View raw message