cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Openvswitch + ACS networking
Date Mon, 01 Jun 2020 14:31:09 GMT
Worth reading on this one:
https://www.shapeblue.com/networking-kvm-for-cloudstack-2018-revisit-for-centos7-and-ubuntu-18-04/

regards,
Andrija

On Mon, 1 Jun 2020 at 14:35, Po Dragonwarrior <hungrypo@gmail.com> wrote:

> Hi,
>
> I am trying to setup ACS with openvswitch for advanced networking, but I
> cannot really understand the openvswitch+ACS networking part.
>
> I have a kvm host with 2 nics and I want to use nic1 for
> management+storage traffic, and nic2 for public+guest traffic.
>
> So I use the following
>
> ovs-vsctl add-br cloudbr0
> ovs-vsctl add-port cloudbr0 eth0
> ovs-vsctl add-br cloudbr1
> ovs-vsctl add-port cloudbr1 eth0
>
> then for ifcfg-eth0
> DEVICE=eth0
> HWADDR=00:04:xx:xx:xx:xx (My MAC addr)
> ONBOOT=yes
> HOTPLUG=no
> BOOTPROTO=none
> TYPE=Ethernet
>
> then for ifcfg-eth1
> DEVICE=eth1
> HWADDR=xx:xx:xx:xx:xx:xx (my MAC addr)
> ONBOOT=yes
> HOTPLUG=no
> BOOTPROTO=none
> TYPE=Ethernet
>
>
> for ifcfg-cloudbr0:
> DEVICE=cloudbr0
> ONBOOT=yes
> HOTPLUG=no
> BOOTPROTO=static
> DEVICETYPE=ovs
> TYPE=OVSBridge
> IPADDR=172.16.0.10
> GATEWAY=172.16.0.1
> NETMASK=255.255.255.0
>
> for ifcfg-cloudbr1:
> DEVICE=cloudbr1
> ONBOOT=yes
> HOTPLUG=no
> BOOTPROTO=static
> DEVICETYPE=ovs
> TYPE=OVSBridge
>
> Later on the Web GUI I create two physical networks:
> Physical Network 1 where I add  management and storage (blue and red
> buttons) with traffic label ‘cloudbr0’ and VLAN type
> Physical Network 2 where I add  public and guest (green and yellow
> buttons) with traffic label ‘cloudbr1’ and GRE type
>
> my ip-ranges are:
> pod: 172.16.0.100 - 110
> public: 172.16.0.200 - 210
> guest: vlan 1000-1100
> storage: 172.16.0.50 - 60
>
> After the ACS installation it is obvious that there is no communication
> between the management server and the system vms.
> What is wrong with my setup?…
>
>
>
>

-- 

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message