cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Rolston" <>
Subject RE: SQLProcessor problems
Date Mon, 06 Mar 2000 03:56:48 GMT
I bounced the server and it appears to have fixed it. This has got me
worried as this is about the 7th time that I have bounced it and the
previous 6 times (same source xml, same everything) nothing happened.


-----Original Message-----
From: Bill Rolston []
Sent: Friday, March 03, 2000 9:11 PM
To: Cocoon-Users
Subject: SQLProcessor problems


I'm having problems with the SQLProcessor function. I'm running Apache
1.3.11 with Jserv 1.1-2 and Cocoon 1.6 on Red Hat Linux 2.2.12-20 and I've
tried to create a simple test file and it appears that the tags for creating
the connection (as well as the <query> tag) don't seem to be recognized. For

Test file:

<?xml version="1.0" encoding="UTF-8"?>
<?cocoon-process type="sql"?>

<?xml-stylesheet href="sql_test.xsl" type="text/xsl"?>
<?cocoon-process type="xslt"?>

   <connection name="foo_con">

<query connection="foo_con">
select NAME from EMP


and what I get in the browser window is the following text line:

oracle.jdbc.driver.OracleDriver jdbc:oracle:thin:@XX.XX.XX.XX:1521:hni01d
foobar foobar select NAME from EMP

What this tells me (and I could be wrong) is that the SQLProcessor is not
processing the tags and just spitting out the text in the tags and not
interpreting them. I've looked at the SQLProcessor code (which looks to be
right) but I haven't re-compiled it and put it into the jar (though I'm not
sure of the efficacy of this). Has anyone any ideas as too where to look?
I'm probably missing something obvious but... perhaps a second pair of eyes
will see clearer.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message