cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mario Guzzi" <>
Subject Very strange problems while accessing wap examples provided with Cocoon 1.8 through Nokia WAP Toolkit 2.0!
Date Sat, 06 Nov 1999 14:03:24 GMT

I'm using Cocoon 1.8, Tomcat Web Server 3.1 (and JDK 1.2.2), Nokia WAP Toolkit 2.0. I'm also
using Windows NT 4.0.

I would like to build a Wap application using Cocoon platform.

Cocoon installion works well. Everything is ok if I ues a web browser to access the examples
provided with Cocoon.

The problem I have is that I cannot access the examples provided with Cocoon itself through
the Nokia WAP Toolkit 2.0.

I cannot access both using the Nokia 7110 and the Blueprint phone simulations.

When I try to access the example called example-portfolio.xml using the Nokia 7110 device
I get the following error message: "The page cannot be displayed".

If I use the Blueprint device I get the error message "Character encoding conversion failed"
and then the Nokia WAP Toolkit asks me if I want to see Cocoon's response in a wml editor
(the toolkit's one). I answer that I want to and the Toolkit shows me the right wml code:

<?xml version="1.0" encoding="UTF-8"?>


<wml><card id="index" title="Your Portfolio"><p align="center"><a href="#value">Value</a><br/><a
href="#stocks">Stocks</a><br/></p><do label="About" type="accept"><go
href="#About"/></do></card><card id="about" title="About"><onevent
type="ontimer"><prev/></onevent><timer value="25"/><p align="center"><br/><br/><small>

Copyright รท 1999<br/>

Apache Software Foundation.<br/>

All rights reserved.

</small></p></card><card id="value" title="Portfolio Value"><p>

Total value: <b>$$122786</b><br/><small>(<b>-0.23%</b>
from yesterday)</small><br/><small>(<b>+1.82%</b> from last
week)</small><br/><small>(<b>+1.32%</b> from last month)</small><br/><small>(<b>+45.00%</b>
ever)</small><br/></p><do label="Back" type="prev"><prev/></do></card><card
id="stocks" title="Your Current Stocks"><p align="center"><a href="#Macrosoft">Macrosoft</a><br/><a
href="#HAL">HAL</a><br/><a href="#Riskape">Riskape</a><br/><a
href="#Moon">Moon</a><br/></p><do label="Back" type="prev"><prev/></do></card><card
id="Macrosoft" title="Macrosoft"><p>

Quotes: 300<br/>

Value: 120.42$$<br/><small>(<b>-0.04%</b> from yesterday)</small><br/><small>(<b>+0.49%</b>
from last week)</small><br/><small>(<b>-3.89%</b> from last
month)</small><br/><small>(<b>+459.58%</b> ever)</small><br/></p><do
label="Back" type="prev"><prev/></do></card><card id="HAL" title="HAL"><p>

Quotes: 1000<br/>

Value: 47.34$$<br/><small>(<b>+0.38%</b> from yesterday)</small><br/><small>(<b>+0.59%</b>
from last week)</small><br/><small>(<b>-1.34%</b> from last
month)</small><br/><small>(<b>-34.53%</b> ever)</small><br/></p><do
label="Back" type="prev"><prev/></do></card><card id="Riskape" title="Riskape"><p>

Quotes: 130<br/>

Value: 85.43$$<br/><small>(<b>-1.34%</b> from yesterday)</small><br/><small>(<b>-10.49%</b>
from last week)</small><br/><small>(<b>+4.89%</b> from last
month)</small><br/><small>(<b>+50.58%</b> ever)</small><br/></p><do
label="Back" type="prev"><prev/></do></card><card id="Moon" title="Moon"><p>

Quotes: 500<br/>

Value: 56.43$$<br/><small>(<b>+0.44%</b> from yesterday)</small><br/><small>(<b>+2.38%</b>
from last week)</small><br/><small>(<b>-0.2%</b> from last month)</small><br/><small>(<b>+87.03%</b>
ever)</small><br/></p><do label="Back" type="prev"><prev/></do></card></wml>

<!-- This page was served in 421 milliseconds by Cocoon 1.8 -->

At this point I save this file as "test.wml". If I try to either or compile it I get the "character
encoding conversion

failed" error again.

But if I type its URL in the Toolkit's browers it gets loaded and executed both on the Blueprint
and on the 7110 Nokia Phones. That is to say everything is ok! Very stange, isn't it?

At the beginnig I started to think it was due to the fact I had to set web server's MIME types.
So I tried to configure Tomcat's MIME type, putting a few lines in the file called "web.xml",
but it doesn't work.

Then I tried to configure phone settings in order to make them using the Nokia WAP Server
(a gateway). But nothing changed.

I hope you can help me solve this boring problem once and for all. This way I colud build
my wap application using Cocoon.

Best regards!

Mario Guzzi.

View raw message