cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anders Conrad" ...@dsl.dk>
Subject Re: Cocoon + FOP
Date Fri, 11 Jan 2002 09:51:54 GMT
It is in the Cocoon 1 FAQ at
http://xml.apache.org/cocoon1/faqs.html#faq-iepdfbug

Anders
----- Original Message ----- 
  From: Stephan Kassanke 
  To: cocoon-users@xml.apache.org 
  Sent: Thursday, January 10, 2002 4:47 PM
  Subject: Re: Cocoon + FOP


  TJ,

  it's documented here in the NG. I think it did not make its way into the cocoon or FOP documentation
(yet?). Actually it is a MS IE bug (only in 5.0) as far as I know. Later versions do not have
this behaviour. Anyway, MS seems to be ignoring to this issue.

  Stephan
    ----- Original Message ----- 
    From: TJ Smith 
    To: cocoon-users@xml.apache.org 
    Sent: Thursday, January 10, 2002 6:17 AM
    Subject: Re: Cocoon + FOP


    Thanks very much - both suggestions work!  A couple of questions tho;
    where is Matthias' suggestion documented?  I've perused the Microsoft tech notes, etc.
and didn't find the 'a=b.pdf' workaround.  Just curious :-)

    Thanx again
    TJ
      ----- Original Message ----- 
      From: Sidharth 
      To: cocoon-users@xml.apache.org 
      Sent: Sunday, January 06, 2002 3:36 AM
      Subject: Re: Cocoon + FOP


      Well I encounetred the same problem for which I downloade the .20 version and succesfully
completed the pdf conversions.
      If u want to open in a browser, then there is a servlet FOPServlet.java just forward
the request from a jsp to that servlet and try.
        ----- Original Message ----- 
        From: Matthias Fischer 
        To: cocoon-users@xml.apache.org 
        Sent: Wednesday, January 09, 2002 1:34 PM
        Subject: RE: Cocoon + FOP


        Have you tried to add in your browser command line the following?

        http://[path][filename].pdf?a=b.pdf

        Sometimes IE is a bit slow to understand that a pdf is a pdf...

        Matthias  

          -----Original Message-----
          From: TJ Smith [mailto:tj@tjinc.com]
          Sent: Tuesday, January 08, 2002 7:06 PM
          To: cocoon-users@xml.apache.org
          Subject: Cocoon + FOP


          Hi all
          I'm using Windows 2000, Tomcat 3.3, Cocoon 1.8.2 and the FOP they came with: Fop_0_15_0.
 All are installed correctly and produce the correct output - except for PDF output.  The
problem is accessing an xml file thru Cocoon.  Tomcat reports encouraging messages culminating
with

          rendering out PDF
          writing out PDF

          However, the IE browser (version 5.5) screen remains blank.

          I have perused the e-mail correspondence and see there are a number of similar problems
reported - none seem to have worked in my case, this includes tacking strange suffixes to
a url: 'iedebug=.pdf', etc.  I have tried moving up to Fop version 0.20.1 which generates
a number of error messages.

          With all due apologies if I have missed the solution somewhere, can someone kindly
fill me in?  I'm getting a tad desperate :-)

          TJ


------------------------------------------------------------------------


        ---------------------------------------------------------------------
        Please check that your question has not already been answered in the
        FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

        To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
        For additional commands, e-mail: <cocoon-users-help@xml.apache.org>

Mime
View raw message