cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Caswell" <stevencasw...@yahoo.com>
Subject RE: problems with StreamGenerator...
Date Thu, 14 Feb 2002 00:06:07 GMT
Thanks for the info.  Will try out the updated class soon.

-----Original Message-----
From: giacomo [mailto:giacomo@apache.org] 
Sent: Monday, February 11, 2002 3:48 PM
To: cocoon-users@xml.apache.org; stevencaswell@yahoo.com
Subject: RE: problems with StreamGenerator...


On Mon, 11 Feb 2002, Steven Caswell wrote:

> Greetings.  I am having the same problem Joe described below. 
> Basically, I'm trying to use the StreamGenerator with a stream of XML 
> (content-type of text/xml).  I've tried the sample code posted by 
> Kinga, but the web server just takes over the CPU and never responds.
>
> I'm trying this on Cocoon 2.0.1, Tomcat 4.0.1, on Windows XP.  Any 
> help diagnosing the problem is appreciated.

There has been a bug in a class which generates a loop under Tomcat 4.x.
It is fixed in the Cocoon CVS. The class in question can be found here:

http://cvs.apache.org/viewcvs.cgi/xml-cocoon2/src/java/org/apache/cocoon
/util/PostInputStream.java

Giacomo

> >
> > Hi,
> > the expected contents of the postData is a xml document. You can add
> to your
> > client application sending POST request the ability to read the
> external xml
> > document. Find any well formed xml doc and experiment. Consider 
> > adding to your client: ...
> [snip]
> >> -----Original Message-----
> >> From: Joseph Jupin [mailto:joe.jupin@fe77.com]
> >> Sent: Wednesday, January 30, 2002 4:36 PM
> >> To: cocoon-users@xml.apache.org
> >> Subject: Re: problems with StreamGenerator...
> >>
> >>
> >> Hi, Kinga...
> >>
> >> Thanx for taking time to talk about this.  But so far, that 
> >> solution's not working either.  Just a quick question
> >> - does the contents of the postData need to be of the form 
> >> "?foo=data" and does the data segment need to be url encoded?
> >>
> >> I've put your suggestions in and so far, the server hangs
> >> - it never responds back - and doesn't even act like it's been 
> >> queried...  kinda strange...
> >>
> >> again, many thanx...
> >>
> >> peace.  JOe...
>
>
>
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com
>
>
> ---------------------------------------------------------------------
> Please check that your question has not already been answered in the 
> FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>
>
> To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
> For additional commands, e-mail: <cocoon-users-help@xml.apache.org>
>
>
>
>


---------------------------------------------------------------------
Please check that your question has not already been answered in the FAQ
before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>



_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message