cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@dvs1.informatik.tu-darmstadt.de>
Subject Re: [HELP] Cocoon 2.0 - Oracle DB connection problems...
Date Wed, 06 Mar 2002 09:05:52 GMT
Srinivas,

On 05.Mar.2002 -- 09:50 PM, CHERVIRALA Srinivas / FTR&D / US wrote:
> 
> I tried with Tomcat 4.01 with out any success.
> 
> My error.log file contains the following:
> 
> FATAL_E (2002-03-05) 21:10.56:416   [core] (Unknown-URI) Unknown-thread/LogKitLogger:
Excalibur could not create any connections. Examine your settings to make sure they are correct.
 Make sure you can connect with the same settings on your machine.
> ERROR   (2002-03-05) 21:13.11:932   [sitemap.generator.velocity] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/VelocityGenerator: ResourceManager : unable to find resource 'VM_global_library.vm'
in any resource loader.
> ERROR   (2002-03-05) 21:13.12:760   [sitemap.generator.velocity] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/VelocityGenerator: ResourceManager : unable to find resource 'VM_global_library.vm'
in any resource loader.
> ERROR   (2002-03-05) 21:13.13:385   [sitemap.generator.xmldb] (/cocoon/xsp/esql1) HttpProcessor[8080][4]/XMLDBGenerator:
There was a problem setting up the connection
> ERROR   (2002-03-05) 21:13.13:385   [sitemap.generator.xmldb] (/cocoon/xsp/esql1) HttpProcessor[8080][4]/XMLDBGenerator:
Make sure that your driver is available
> ERROR   (2002-03-05) 21:13.13:385   [sitemap.generator.xmldb] (/cocoon/xsp/esql1) HttpProcessor[8080][4]/XMLDBGenerator:
There was a problem setting up the connection 
> ERROR   (2002-03-05) 21:13.13:385   [sitemap.generator.xmldb] (/cocoon/xsp/esql1) HttpProcessor[8080][4]/XMLDBGenerator:
Make sure that your driver is available
> ERROR   (2002-03-05) 21:13.13:401   [sitemap.generator.xmldbcollection] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/XMLDBCollectionGenerator: There was a problem setting up the connection
> ERROR   (2002-03-05) 21:13.13:401   [sitemap.generator.xmldbcollection] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/XMLDBCollectionGenerator: Make sure that your driver is available
> ERROR   (2002-03-05) 21:13.13:416   [sitemap.generator.xmldbcollection] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/XMLDBCollectionGenerator: There was a problem setting up the connection
> ERROR   (2002-03-05) 21:13.13:416   [sitemap.generator.xmldbcollection] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/XMLDBCollectionGenerator: Make sure that your driver is available
> ERROR   (2002-03-05) 21:13.49:573   [sitemap.generator.serverpages] (/cocoon/xsp/esql1)
HttpProcessor[8080][4]/esql1_xsp: Could not get the datasource org.apache.avalon.excalibur.datasource.NoAvailableConnectionException:
There are no connections in the pool, check your settings.

could you please look up the same portion in core.log? It is usually a
bit informative. 

> I would like to know whether I need to change any settings in any files
> other than the following:
> 
> 1) web.xml --> added Oracle JDBC driver in load-class section

OK

> 2) cocoon.xconf --> added datasource

OK

> 3) Copied classes12.jar to cocoon\web-inf\lib

OK (no idea about Oracle, though. Doesn't look like an Oracle driver
   to me)

> 4) sitemap.xmap --> <map:parameter name="use-connection"
> value="MyOrclConn"/>

OK

> 5) esql1.xsp -->
> <esql:connection>
>      <esql:pool>MyOrclConn</esql:pool>
>      <esql:execute-query>
>        <esql:query>select * from test</esql:query>
>        <esql:results>
>          <esql:row-results>
>            <para><esql:get-string column="name"/></para>
>            <esql:get-columns/>
>          </esql:row-results>
>        </esql:results>
>      </esql:execute-query>
>    </esql:connection>

OK

> When I tried to run the XSP file I got the following error:
> The org.apache.cocoon.www.sitemap_xmap notifies that
> org.apache.cocoon.ProcessingException says:
> 
> Exception in ServerPagesGenerator.generate() 
> 
> More precisely:
> 
> org.apache.cocoon.ProcessingException: Exception in ServerPagesGenerator.generate():
java.lang.RuntimeException: Could not get the datasource org.apache.avalon.excalibur.datasource.NoAvailableConnectionException:
There are no connections in the pool, check your settings. 

Setting up the pool went wrong -- there's really no point in trying
the esql without the pool being established. You could try to connect
on your xsp using <esql:driver/> <esql:user/> <esql:password/>
<esql:dburl/> (off my head, check exact element names) -- but I would
expect that to fail as well.

Which version of Cocoon are you using? If source distributions, how
did you build it (I have some problem with datasources, scratchpad and
current CVS but your logs don't show the relevant bits so I can't say
if it's related.)

> 6) Finally I overwrote the esql.xsp with my esql1.xsp and accessed the
> esql.xsp, the output that I got is related to the earlier esql.xsp (which is
> sample xsp page). I stopped the tomcat and restarted ..no change in output.
> Isn't this crazy.

No surprise here. If it's the connection a correct XSP wouldn't change
the error.

	Chris.

-- 
C h r i s t i a n       H a u l
haul@informatik.tu-darmstadt.de
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message