cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yuryx <yu...@mobicomk.donpac.ru>
Subject Re: Apache and mod_jk (could not get mod_webapp working)
Date Wed, 13 Mar 2002 15:40:15 GMT
For configure mod_webapp read :
http://www.galatea.com/flashguides/apache-tomcat-4-unix.xml

Regards.
Yury.

Frank Ridderbusch wrote:

>Hi folks,
>
>I like to share a couple of experiences, which I learned the hard way
>and I learned them, while trying to get Cocoon working through Apache.
>They might have been obvious to someone else, but anyway.
>
>First I tried mod_webapp. I configured it like this
>
> <IfModule mod_webapp.c>
> Include /etc/httpd/mod_webapp.conf
> </IfModule>
>
>while mod_webapp.conf contained the actual directives. The result was,
>that it didn't work. Looking at /server-info I saw this:
>
> Module Name: mod_webapp.c
> Content handlers: webapp-handler
> Configuration Phase Participation: Child Init, Child Exit
> Request Phase Participation: Translate Path
> Module Directives:
> WebAppInfo - 
> WebAppConnection - [optional parameter] 
> WebAppDeploy - 
> Current Configuration: 
>
>No configuration visible. I think here is an issue with the include
>mechanism. Then I configured it like this:
>
> <IfModule mod_webapp.c>
> WebAppConnection conn      warp  localhost:8008
> WebAppDeploy     examples  conn  /examples
> WebAppDeploy     cocoon    conn  /cocoon
> WebAppDeploy     scarab    conn  /scarab
>
> WebAppInfo /webapp-info
> </IfModule>
>
>This showed the correct configuration in /server-info, but when I tried
>/cocoon/welcome, after some period of burning cpu cycles, I received an
>error message about some "internal error" (I used cocoon CVS shnapshot
>from Tuesday). So, this didn't work. Perhaps someone else has other
>experiences.
>
>Then I moved to mod_jk. I had used mod_jk with tomcat 3.2 and cocoon
>1.8.x. So, I had a configuration left apart from having moved on to
>tomcat 4.0.1. 
>
>First lesson learned:
>
>  You need a workers.properties file for mod_jk. However tomcat 4.0 does
>  not include one. First I though: "Ah, simply set this to /dev/null,
>  it's  not needed", but this didn't work. mod_jk needs the
>  workers.properties to configure the ajp ports correctly. Using one
>  from tomcat 3.2 made it work.
>
>Second lesson learned:
>
>  Remove an "Alias" for cocoon, if you have one left in your httpd.conf.
>  My previous configuration from cocoon 1.8.x  contained a line like
>
>    Alias /cocoon "/usr/local/httpd/tomcat/webapps/cocoon"
>
>  Selecting "/cocoon/hello.html" from the cocoon welcome page would
>  produce a 404 error, since apache tries to satisfy this request,
>  instead of passing it to tomcat.
>
>Hope, this helps someone else.
>




---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message