cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark.Vo...@weirdtable.org
Subject cocoon 2.0 with Tomcat 4.1 installation problems
Date Fri, 01 Mar 2002 15:42:52 GMT

Hi,

I've spent several hours trying to install Cocoon2.0 on top of Tomcat4.1
and it still isn't running. I donwloaded version 2.0.1 and that wouldn't
even
build. So I downloaded version 2.0. According to the install instructions,
with Cocoon 2.0 and Tomcat 4.x, the setup is supposed to be a piece of
cake. Just run the build.bat, which will generate the
/build/cocoon/cocoon.war and then simply copy that cocoon.war into
tomcat/webapps. Then start up Tomcat and voila! When I start up Tomcat,
there's definite noise in my machine and cocoon begins to compile it's
classes, but I get errors from the Servlet Container when I try to hit it
via the browser. Primarily, can't find some classes and
NullPointerExceptions. I thought that the older version of the parser issue
might have been it, and I tried putting in the latest xerces.jar inside
Tomcat and renaming the older .jar, but in any case Tomcat 4.x claims to
have the later xerces.jar version already. I was also using jdk1.4 and
thought that might have been a problem, because a version of xerces.jar is
included with that, so I installed jdk1.3, but I still get an error trying
to start up cocoon. Has anyone seen this? Should I be using an earlier
version of the products maybe?

Thanks,
Mark.


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message