cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Derek Hohls" <DHo...@csir.co.za>
Subject Pipeline Matching Problems
Date Tue, 19 Mar 2002 13:18:33 GMT
Running C2.0 under Windows 2000, JDK 1.3, Apache/Tomcat

I am trying to get a small database working.  After failing to
get it working in a submap, I have tried moving all the relevant 
files over to the Cocoon samples directory.  

When I have:

   <map:match pattern="docs/samples/forms/form_chemicals">
       <map:generate type="serverpages"
src="docs/samples/forms/form_chemicals.xsp"/>
       <map:transform src="docs/samples/styles/dbform.xsl"/>
       <map:serialize />
   </map:match> 

all is well, and the output from the database output displays as
expected.

But when I try and use actions:

   <map:match pattern="docs/samples/forms/form_chemicals">
     <map:act set="dbentry">
       <map:parameter name="descriptor" 
value="context://docs/samples/forms/desc_chemicals.xml" />
       <map:generate  type="serverpages"
src="docs/samples/forms/form_chemicals.xsp"/>
       <map:transform src="docs/samples/styles/dbform.xsl"/>
       <map:serialize />
     </map:act>      
   </map:match>

I get the error message in the root log:

WARN    (2002-03-19) 15:03.20:994   [root    ]
(/cocoon/docs/samples/forms/form_chemicals)
 HttpProcessor[8080][4]/CocoonServlet: The resource was not found
org.apache.cocoon.ResourceNotFoundException: 
No pipeline matched request: /docs/samples/forms/form_chemicals

The action set and descriptor all exist in the relevant directories,
and the action set is also
defined in the relevant sitemap entry.  The Tomcat work directory was
clean.

Any clues as to why pattern is not matched?

Thanks
Derek

PS I have tried changing:
<map:parameter name="descriptor"  value="contex
to
<map:parameter name="descriptor"  value="file
on other advice, but without succcess.

---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message