cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vadim.gritse...@verizon.net>
Subject RE: Saxon Xinclude problem
Date Tue, 07 May 2002 20:47:59 GMT
> From: Artur Bialecki [mailto:artur@digitalfairway.com]
> 
> 
> I have a problem with Saxon 6.5.2 and Xinclude transformer.
> I get the following:
> 
> java.lang.NoClassDefFoundError: org/apache/xpath/XPathAPI
>         at
>
org.apache.avalon.excalibur.xml.xpath.XPathProcessorImpl.selectNodeList(
XPathP
> rocessorImpl.java:65)
>         at
>
org.apache.cocoon.transformation.XIncludeTransformer.processXIncludeElem
ent(XI
> ncludeTransformer.java:302)
>         at
>
org.apache.cocoon.transformation.XIncludeTransformer.startElement(XInclu
deTran
> sformer.java:155)
>         at
>
org.apache.cocoon.www.oem.customer.index_xml.generate(index_xml.java:764
)
> 
> Do I have to keep xalan.jar for the XPathAPI or do I use something
> else. How can I get this to work.

Either this or try switching to Jaxen (other XPath engine). Drop it into
lib/optional and do full rebuild.


Vadim


> Thanks,
> 
> Artur...
> 


---------------------------------------------------------------------
Please check that your question has not already been answered in the
FAQ before posting. <http://xml.apache.org/cocoon/faqs.html>

To unsubscribe, e-mail: <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail: <cocoon-users-help@xml.apache.org>


Mime
View raw message