cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjé Cahn <A...@hippo.nl>
Subject RE: encoding problem
Date Mon, 17 Jun 2002 09:44:02 GMT
Sjoerd,

I believe the HTML serializer outputs html entities by default.
This is recommended, as all browsers on all platforms support entities, independent of the
character set on the machine. If you really need the characters, you could serialize to XML
instead of HTML. Also, using unicode characters in URL's is not recommended. We experienced
this  on the website of Duitsland Instituut Amsterdam (www.duitslandweb.nl). You might want
to take a look at it, as it runs on Cocoon and uses a lot of German characters.

If you have further Cocoon questions, don't hesitate to mail or call me (020 6345173).

Regards,

Arjé Cahn


---------------------------------------------------------
Content Management Department
Hippo Webworks
Grasweg 35
1031 HW Amsterdam
The Netherlands
Tel  +31 (0)20 6345173 
Fax +31 (0)20 6345179
arje(at)hippo(dot)nl / www.hippo.nl



-----Oorspronkelijk bericht-----
Van: S.M. Siebinga [mailto:Sjoerd.Siebinga@student.uva.nl]
Verzonden: 14 June 2002 21:46
Aan: cocoon-users@xml.apache.org
Onderwerp: encoding problem


Hi all,

I have a small encoding problem in cocoon 2.0.2. I have a utf-8 encoded
text that is transformed to html with an xsl stylesheet. After the
processing the unicode characters aren't displayed properly. When I
looked at the page source my characters were hardcoded in html entities
like & Aumlaut; when it should have been an a with a macron. When I
processed the xml source and the stylesheet by xalan it worked fine. 

Furthermore some of the unicode characters in hyperlinks are displayed
properly in the status bar at the bottom of my browser but aren't in the
main browser window. This led me to conclude that the problem most be
somewhere internally in cocoon.

When I looked through the log files I couldn't find any noticable
exceptions.

Could somebody please help me out?

I have a sdk 1.3.1 on a SuSE linux 8.0 box and cocoon 2.0.2 is running
on tomcat 4.0.1

regards sjoerd


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


---------------------------------------------------------------------
Please check that your question  has not already been answered in the
FAQ before posting.     <http://xml.apache.org/cocoon/faq/index.html>

To unsubscribe, e-mail:     <cocoon-users-unsubscribe@xml.apache.org>
For additional commands, e-mail:   <cocoon-users-help@xml.apache.org>


Mime
View raw message