cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Greenyer <>
Subject Problem with cinclude transformer in Cocoon 2.1
Date Fri, 25 Apr 2003 10:57:12 GMT
Hello Users,
after moving from Cocoon 2.0.4 to Cocoon 2.1 I now encounter a problem 
with the cinclude transformer.
As described here
I try to construct a post request like this:

                    <!-- RIGHT HERE -->

The <xsl:apply-templates/> will fill the 
<cinclude:value></cinclude:value> with the content of a complete XML-File.
Now the XML-Declaration (e.g. <?xml version="1.0" encoding="UTF-8"?>) is 
left out and won't be saved by the save-action I am posting to.
To work around that problem I tried this

                    <![CDATA[<?xml version="1.0" encoding="UTF-8"?>]]>

which worked in Cocoon 2.0.4.
In Cocoon 2.1 the (saved) result looks like this:
                &lt;?xml version="1.0" encoding="UTF-8"?&gt;

Is there any way to manually add the correct XML-declarations to the 
Or - which would be even better - is there any way to post the original 
XML-declaration of my XML-File?

Any help would be great!


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message