cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sushil Bhattarai" <sush...@hotmail.com>
Subject Re: JSP Again
Date Tue, 01 Apr 2003 14:36:07 GMT
Newer version of JBoss (JBoss Web) comes with Jetty. I'm using JBoss 3.0.4 
and I'm trying to get JSP work in my cocoon. Rest of the Cocoon stuff work 
fine, only JSP seems to be giving problem. I added jasper-compiler.jar 
because I read in one of the discussion list that it is needed for JSP to 
work. It's not helping here though.

Sushil
>
>This looks like an error in your JSP or in the Jasper compiler. Take a look 
>at the generated source to see what's wrong. And also it's a little strange 
>that the java file for your JSP is generated in a ...\Jetty...\ directory. 
>Are you using Tomcat? I'm not sure that Jasper compiler works with Jetty.
>
>Konstantin
>
>----- Original Message ----- From: Sushil Bhattarai To: 
>cocoon-users@xml.apache.org Sent: Tuesday, April 01, 2003 01:41 Subject: 
>JSP Again
>
>
>Hi all, Previously I've had problem with JSP but I was able to fix it. Then 
>I was using older version of Cocoon and Tomcat as the server. Now I'm using 
>cocoon-2.0.4 on JBoss 3.0.4. Both JSP Generator and JSPReader do not seem 
>to work. I tried adding jasper-compiler.jar and jasper-runtime.jar to 
>WEB-INF/lib in my cocoon. Still it does not like it. Without adding 
>jasper-runtime, I get error regarding jasper-runtime. After adding it I get 
>the following error: org.apache.jasper.JasperException: Unable to compile 
>class for JSPNote: sun.tools.javac.Main has been deprecated. 
>C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Jetty_0_0_0_0_8080__ssfxml\ssftalklets\sa 
>mples\jsp\hello$jsp.java:67: Incompatible type for method. Explicit cast 
>needed to convert java.lang.Throwable to java.lang.Exception. if 
>(pageContext != null) pageContext.handlePageException(t); ^ 1 error, 1 
>warning at org.apache.jasper.compiler.Compiler.compile(Compiler.java:285) 
>at org.apache.jasper.servlet.JspServlet.loadJSP(JspServlet.java:548) at 
>org.apache.jasper.servlet.JspServlet$JspServletWrapper.loadIfNecessary(JspSe 
>rvlet.java:176) ............... Addition of jasper-compiler.jar makes no 
>difference. Has anyone been able to get JSP to work with cocoon-2.0.4 on 
>JBoss Server ?? Sushil
>
>
>
>Help STOP SPAM with the new MSN 8 and get 2 months FREE* 
>--------------------------------------------------------------------- To 
>unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org For additional 
>commands, e-mail: cocoon-users-help@xml.apache.org
>
>
>--------------------------------------------------------------------- To 
>unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org For additional 
>commands, e-mail: cocoon-users-help@xml.apache.org
>

_________________________________________________________________
Protect your PC - get McAfee.com VirusScan Online  
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message