cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cumming...@netscape.net (Steven Cummings)
Subject Re: Unable to get transformer handler for stylesheets/blah.xsl
Date Tue, 03 Jun 2003 22:13:33 GMT
Joerg

Well, the tip really worked well. I don't quite get it, but the transform works all of the
sudden. So that leads to the question, is there (and I haven't checked Bugzilla for Xalan
or XSLTC) a bug in XSLTC related to this (maybe includes)? I'll definitely look into it but
if someone already smells a problem I would work with someone more knowledgeable to build
a test-case. Thanks again, Joerg.

/S

cummingscs@netscape.net (Steven Cummings) wrote:

>Joerg,
>
>Yes, in the original message I had attached the stylesheet, which <xsl:include>'d
another, which <xsl:include>'d a third stylesheet (I attached all three of them). They
are viewable here:
>http://marc.theaimsgroup.com/?l=xml-cocoon-users&m=105467465417098&w=2
>if your mail client didn't show them.
>
>Anyway, I'll give the xalan transformer a shot and see what happens, thanks for the tip!
>
>/S
>
>Joerg Heinicke <joerg.heinicke@gmx.de> wrote:
>
>>Hello Steven,
>>
>>it's XSLTC who does give so exhaustive messages. Try to use Xalan for 
>>this particular transformation, maybe you get a real error message.
>>
>>Are you refering external resources from the stylesheet (xsl:import, 
>>xsl:include, document())?
>>
>>Joerg
>>
>>Steven Cummings wrote:
>>> Hello,
>>> 
>>> Is anybody else getting this sort of an error in 2.1m2 or 2.1cvs
>>> (shown below the main text of this message)? I went through the
>>> Cocoon sources for TraxTransformer, which led me to XSLTProcessorImpl
>>> from Avalon-Excalibur and the piece of code I found (around
>>> XSLTProcessorImpl.java:320) indicated that the Templates instance
>>> obtained from the TemplateHandler is null, which of course propogated
>>> to the message seen below. This leads me to believe that there is a
>>> problem with the stylesheet, but there really isn't. It's just a
>>> modified version of dynamic-page2html.xsl from Cocoon itself, and has
>>> worked for me up until I tried upgrading to m2 or cvs.
>>> 
>>> Here's where the problem (see messages below) gets worse. I have
>>> another webapp, also built on 2.1m2, and when they are running side
>>> by side in the same tomcat container, the other one works and this
>>> one doesn't. They each have some (separate) XSLTs that they use for
>>> rendering. They both have the exact same set of components included
>>> and the same set excluded  (commented-out) from the default
>>> cocoon.xconf. Their logkit.xconf and instrumentation.xconf files are
>>> identical. Their web.xml files are the same except for the
>>> application display-name. Finally, their sets of jar-files in
>>> WEB-INF/lib are identifical. I know most of these details will have
>>> nothing to do with the problem, but I thought I'd include them
>>> anyway.
>>> 
>>> I've also attached the stylesheet that I get the error for, and the
>>> stylesheets that it includes. I don't know if other stylesheets get
>>> the same error and it is not specific to this one because the
>>> remaining pipelines are behind auth-protect actions and I haven't yet
>>> taken the time to move some to un-protected pipelines/matches so that
>>> they could be tested for the problem (and a lot of them depend on
>>> auth-contexts anyway).
>>> 
>>> This seems like such a fundamental type of problem that I must be
>>> missing something. Can anybody with experience with these newer
>>> versions of cocoon see what might be my problem?
>>> 
>>> TIA /S
>>> 
>>> Relevant info: Windows XP Java 1.4.1_02 Tomcat 4.1.24 (LE-jdk14) 
>>> Cocoon 2.1m2 (2.1cvs has been tried as well)
>>> 
>>> Here is the page-output for the error:
>>> 
>>> --------------------->8-----------------------------------------------------
>>>  Message: null Description: No details available. Sender:
>>> org.apache.cocoon.servlet.CocoonServlet Source: Cocoon Servlet
>>> 
>>> Request URI loginpage
>>> 
>>> cause Unable to create templates for stylesheet:
>>> file:/path/to/stylesheets/blah.xsl
>>> 
>>> request-uri /my-app/loginpage 
>>> ----------------------8<----------------------------------------------------
>>> 
>>> 
>>> Here are the details from error.log:
>>> 
>>> --------------------->8-----------------------------------------------------
>>>  org.apache.cocoon.ProcessingException: Unable to get transformer
>>> handler for stylesheets/blah.xsl:
>>> org.apache.excalibur.xml.xslt.XSLTProcessorException: Exception in
>>> creating Transform Handler at
>>> org.apache.cocoon.transformation.TraxTransformer.setup(TraxTransformer.java:307)
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
>>For additional commands, e-mail: cocoon-users-help@xml.apache.org
>>
>>
>
>
>-- 
>Steven Cummings
>Columbia, MO
>Email: cummingscs@netscape.net
>AIM:   cummingscs
>ICQ:   3330114
>MSN:   cscummings@hotmail.com
>
>
>__________________________________________________________________
>McAfee VirusScan Online from the Netscape Network.
>Comprehensive protection for your entire computer. Get your free trial today!
>http://channels.netscape.com/ns/computing/mcafee/index.jsp?promo=393397
>
>Get AOL Instant Messenger 5.1 free of charge.  Download Now!
>http://aim.aol.com/aimnew/Aim/register.adp?promo=380455
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
>For additional commands, e-mail: cocoon-users-help@xml.apache.org
>
>


-- 
Steven Cummings
Columbia, MO
Email: cummingscs@netscape.net
AIM:   cummingscs
ICQ:   3330114
MSN:   cscummings@hotmail.com


__________________________________________________________________
McAfee VirusScan Online from the Netscape Network.
Comprehensive protection for your entire computer. Get your free trial today!
http://channels.netscape.com/ns/computing/mcafee/index.jsp?promo=393397

Get AOL Instant Messenger 5.1 free of charge.  Download Now!
http://aim.aol.com/aimnew/Aim/register.adp?promo=380455

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


Mime
View raw message