cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <>
Subject Re: cocoon2.1 causing ungraceful shutdown on Tomcat4.1.18 ?
Date Mon, 09 Jun 2003 10:33:12 GMT
e nio dijo:
>   I have cocoon2.1dev and the newer cocoon2.1m2 which I observed
> when deployed on Tomcat 4.1.18, causes Tomcat not to shutdown
> gracefully. I get that status of Servlet did not call
> System.exit().  You can try and verify my observation if you
> have the Tomcat4.1.18 and start it with  ./ start
> command. fyi i have jdk1.4.0_01.

There is also the J2SDK 1.4.1_03 it works a little more smooth. I use it
every day and seems to be stable.

>   The only way I can kill the process is via a kill -15
> javathatstartedcocoonpid.

Hey?! are you tried kill -9? This is THE real killer! lol.

>  The effect may not be apparent but it
> was causing a major headache for me because I also have
> Jetspeed1.4-b4 that does not come up on subsequent restart of
> Tomcat due to Tomcat ungraceful exit.
> Anyone else experience this?

Yes, everybody. This is a current bug. In Cocoon:

A WORKAROUND is at the endo of the link. To developers, please confirm
this bug.

I also noted there is another bug in tomcat, but I am not sure if this is
total related to the above. In Tomcat:

I am not a guru to tell if this is the same error.

Best Regards,

Antonio Gallardo

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message