cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Ferner" <josephfer...@cox.net>
Subject Importing a class that uses log4j
Date Sun, 07 Sep 2003 20:16:14 GMT
I just started working with cocoon this Friday so cut me some slack if
this problem has already been covered.

I am working with the latest binary dist of cocoon as of Friday
(9/5/2003) and I am trying to use a class (not mine) which uses log4j
for logging.  The class outputs log entries fine when I run it using
junit and initialize log4j with "PropertyConfigurator.configure(...)"
but when I run it within a web container I get nothing but "Axis" log
messages.

My log4j properties file looks like this:
log4j.rootCategory=debug, A1
log4j.appender.A1=org.apache.log4j.RollingFileAppender
log4j.appender.A1.File=/logs/log4j.log
log4j.appender.A1.MaxFileSize=10MB
log4j.appender.A1.MaxBackupIndex=7
log4j.appender.A1.layout=org.apache.log4j.PatternLayout
log4j.appender.A1.layout.ConversionPattern=%d: %p: %c: %m%n


Unfortunately I only have the .class files for these classes so I can't
modify them.

Thanks in advance and keep up the good work... Advanced Control Flow
rocks.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message