cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reinhard Poetz" <reinh...@apache.org>
Subject RE: Flowscript problem?
Date Thu, 25 Sep 2003 10:43:14 GMT

From: Francis Vermeulen

> Hi,
> 
> I'm trying to use the flowscript capabilities for my 
> application but it appears not to be working. The problem I'm 
> experiencing is that when an earlier Continuation is resumed, 
> it appears that the local variables do not have the value 
> corresponding to that continuation. Here is the script I'm
> testing:

<snip text="yourCode"/>

> Looking at the local variable "test", if I use the browser 
> back button to the very first page and submit it again, I 
> epxect it to have the value '1', but it actually has the 
> value '2', corresponding to the continuation after the 
> "reason-input" page. If I set a breakpoint in the code and 
> inspect the Continuation object, it has changed after the 
> second continuation.
> 
> So it looks like this is a bug, but I'm not really sure. 
> Maybe anybody has the same experience and knows what I'm doing wrong?

This is the intended behaviour because it would cause high memory
consumption if you connect the complete state of your application with a
continuation --> acontinuation "only" represents a certain point at your
flowscript where the script can be continued.

Reinhard


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message