cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepak Mehta <d...@deeeep.com>
Subject Complex Cocoon setup: partial problem solved
Date Tue, 09 Sep 2003 19:08:38 GMT
Hi,

See my older email for reference on the setup: MacOSX 10.2.6, JDK 
1.4.1, JOnAS 3.2.2, Tomcat 4.1.27 and Cocoon 2.1.1...

Solved a classloader problem by using the Paranoid option in web.xml 
(read the fucking manuals or textfiles!)... Peoples this might solve 
some problems for other people too... try it!

The nice thing is you don't even need to move the x*.jar files...

Now the nagging question is: 'What are the downsides of this approach?'

Now that I have the Cocoon 2.1.1 working my other question is:

For the old app I used 2.0.4 and these two actions:
<map:action name="form-validator" 
src="org.apache.cocoon.acting.FormValidatorAction"/>
<map:action name="db-authenticator" 
src="org.apache.cocoon.acting.DatabaseAuthenticatorAction"/>

But they do not work anymore in 2.1.1... what is the easiest way to 
upgrade to the 2.1.1 authentication framework... is there a suggested 
migration path? Maybe write an XSLT which tranforms old parameter files 
to new parameter formats... hint hint!

Regards
Deeeep

-- 
Deepak 'Deeeep' Mehta                    **** Zonnebloem Europa bvba 
****
E-mail: deep@deeeep.com
Tel: +32-475-612620

PGP Fingerprint: 837E B8E6 6AF4 6675 2730  0848 7731 09F5 3445 00A5

Money isn't everything, but no money is nothing at all! (S. Rushdie)


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message