cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rui Alberto L." Gonçalves <rui-l-goncal...@ptinovacao.pt>
Subject Re: aggregate problem
Date Mon, 29 Sep 2003 11:09:11 GMT
Thanks Joerg!!
it's not the difference between CUSTUMISE and CUSTOMISE...
Don't know what's the problem here, but I "solved" adding a
stylesheet in the pipeline that prints back the
result of the aggregation!

<map:match pattern="load_rep-*-*-*">
  <map:aggregate element="UCMS">
	.....
  </map:aggregate>
  <map:transform name="xslt" src="stylesheets/filter.xsl"/>
  <map:transform name="xslt" src="stylesheets/load_rep.xsl"/>
  <map:serialize type="html"/>
</map:match>

filter.xsl: *************
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1.0">
  <xsl:template match="*">
    <xsl:element name="{name()}">
      <xsl:apply-templates select="node()|@*"/>
    </xsl:element>
  </xsl:template>
                                                                                         
                                  
  <xsl:template match="@*">
    <xsl:attribute name="{name()}">
      <xsl:value-of select="current()"/>
    </xsl:attribute>
  </xsl:template>
</xsl:stylesheet>
***************

weird....I'd really like to know what's happening here, but I
can't figure out...
Thanks
Rui Gonçalves




On Fri, 2003-09-26 at 23:24, Joerg Heinicke wrote:
> I never had a problem with aggregation. So I guess it's not the 
> aggregation itself.
> 
> If it's not the difference between CUSTUMISE and CUSTOMISE then it seems 
> to be a problem with SAX events, but I don't know why ...
> 
> Joerg
> 
> Rui Alberto L. Gonçalves wrote:
> 
> > Hi all,
> > I'am working with cocoon 2.0.4, tomcat 4.0.6.
> > I have in my sitemap:
> >     <map:match pattern="load_rep-*-*-*">
> >         <map:aggregate element="UCMS">
> >           <map:part src="http://source1" strip-root="true"/>
> >           <map:part src="http://source2" strip-root="true"/>      
> > 	</map:aggregate>                                                        
                                   
> >         <map:transform name="xslt" src="stylesheets/load_rep.xsl"/>
> >         <map:serialize type="html"/>
> >       </map:match>
> > 
> > the stylesheet load_rep.xsl only match's UCMS element and ignores
> > all the other elements!
> > 
> > say, the document is: <UCMS><CUSTUMISE>xx</CUSTUMISE></UCMS>
> > Match is OK!
> > <xsl:template match="UCMS">
> >  <xsl:apply-templates/>
> > </xsl:template>
> > 
> > <xsl:template match="CUSTUMISE">
> >  This never happens!! Why?!!!
> > </xsl:template>
> > 
> > this template is used and prints |CUSTOMISE| !! 
> > <xsl:template match="*">
> >  |<xsl:value-of select="name()"/>|
> > </xsl:template>
> > 
> > 
> > If I serialize the result as XML, then put it on a file and
> > replace the map:aggregate by <map:generate src="myfile.xml">, everything
> > works fine!!
> > Does anyone have any idea?!!! Encoding problem?! I'am stocked...
> > 
> > Thank's for any help,
> > Rui Gonçalves
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
-- 
Rui Alberto L. Gonçalves <rui-l-goncalves@ptinovacao.pt>
PT Inovação


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message