cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Artur Matos <ama...@create.human.nagoya-u.ac.jp>
Subject Problems using the HTMLGenerator in command line mode 2.1
Date Wed, 03 Sep 2003 11:21:50 GMT
Hi to all,

I am having some problems using the HTML generator with the new
Cocoon 2.1 CLI. The code that I am using was working flawlessy with
the previous Cocoon 2.0.4, so I guess this should be some
problem with the new version. I tried to match a very simple pipeline,
one that generates one HTML file from the filesystem using the HTML
generator, and serializes it into XML, without any further steps in between. I got the following
error:

[java] Cannot find CatalogManager.properties
     [java] Exception in thread "main" java.lang.NoClassDefFoundError: javax/servlet/ServletInputStream
     [java]     at java.lang.Class.getDeclaredConstructors0(Native Method)
     [java]     at java.lang.Class.privateGetDeclaredConstructors(Class.java:1590)

Because I am using only theCLI, I had lots of blocks excluded, and my Webapp didn't include
the 
servlet_2.2.jar file. I copied it, and tried to run the CLI again. I got the following error
instead:

 [java] Exception in thread "main" java.lang.NullPointerException
     [java]     at org.apache.cocoon.generation.HTMLGenerator.setup(HTMLGenerator.java:217)
     [java]     at org.apache.cocoon.components.pipeline.AbstractProcessingPipeline.setupPipeline(AbstractProcessingPipeline.java:381)
     [java]     at org.apache.cocoon.components.pipeline.impl.AbstractCachingProcessingPipeline.setupPipeline(AbstractCachingProcessingPipeline.java:652)

Does anyone on this list had the same problem? Thanks in advance.

Artur Matos.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message