cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agsoftware.dnsalias.com>
Subject Re: Unable to use Woody on latest Cocoon from CVS
Date Fri, 26 Sep 2003 01:34:27 GMT
jcplerm dijo:
> This relates to a problem that I reported some time ago. At that time I
> tried to update Cocoon to the latest CVS version simply by pasting jar
> files onto my existing deployed Cocoon directory tree.
>
> This time I made sure I replaced the entire Cocoon webapp folder with
> the new built from the CVS version downloaded today. I ran build.bat,
> then copied to <TOMCARDIR>/webapps the entire contents of
> cocoon-2.1/build/webapp as <TOMCARDIR>/webapps/cocoon.
>
> I did not modify cocoon.xconf at all. It seems to contain definitions
> for all widgets.
>
> I am able to bring Cocoon up and see its welcome page, as well as
> successfully run portions of my Cocoon application that do not have
> anything to do with Woody.
>
> But when I try to access a form rendered with XML binding, I get this
> exception:
>
> CAUSE: org.apache.avalon.framework.service.ServiceException:
> Non-existing component for this hint (Key='field')
> org.apache.cocoon.woody.binding.BindingException: Cannot handle binding
> element with name "field".

Hi:

Please update again. There are some new changes in woody. I am not really
using woody right now, but soon I will start (next week). I was just
checking the lastest woody examples that works fine.

I think you must check again the examples and review you own code. Woody
is very dynamic and how you work with him today is not true tomorrow.

Best Regards,

Antonio Gallardo




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message