cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: aggregate problem
Date Fri, 26 Sep 2003 22:24:04 GMT
I never had a problem with aggregation. So I guess it's not the 
aggregation itself.

If it's not the difference between CUSTUMISE and CUSTOMISE then it seems 
to be a problem with SAX events, but I don't know why ...

Joerg

Rui Alberto L. Gonçalves wrote:

> Hi all,
> I'am working with cocoon 2.0.4, tomcat 4.0.6.
> I have in my sitemap:
>     <map:match pattern="load_rep-*-*-*">
>         <map:aggregate element="UCMS">
>           <map:part src="http://source1" strip-root="true"/>
>           <map:part src="http://source2" strip-root="true"/>      
> 	</map:aggregate>                                                             
                              
>         <map:transform name="xslt" src="stylesheets/load_rep.xsl"/>
>         <map:serialize type="html"/>
>       </map:match>
> 
> the stylesheet load_rep.xsl only match's UCMS element and ignores
> all the other elements!
> 
> say, the document is: <UCMS><CUSTUMISE>xx</CUSTUMISE></UCMS>
> Match is OK!
> <xsl:template match="UCMS">
>  <xsl:apply-templates/>
> </xsl:template>
> 
> <xsl:template match="CUSTUMISE">
>  This never happens!! Why?!!!
> </xsl:template>
> 
> this template is used and prints |CUSTOMISE| !! 
> <xsl:template match="*">
>  |<xsl:value-of select="name()"/>|
> </xsl:template>
> 
> 
> If I serialize the result as XML, then put it on a file and
> replace the map:aggregate by <map:generate src="myfile.xml">, everything
> works fine!!
> Does anyone have any idea?!!! Encoding problem?! I'am stocked...
> 
> Thank's for any help,
> Rui Gonçalves


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message