cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <>
Subject Re: Cocoon and eclipse
Date Sat, 27 Sep 2003 02:49:06 GMT
Joerg Heinicke wrote:
> Geoff Howard wrote:
>>> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>> That's the one.  You can also set that property in the project directly.
> Hello Geoff,
> I have tried both
> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
> in and
> <target name="properties" if="eclipse.running">
>   <property name="build.compiler" 
> value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
> </target>
> in build.xml (as described at 
> Both don't work:
> compile-core:
> compile-deprecated:
>       [xpatch] BUILD FAILED: java.lang.IllegalArgumentException: No 
> attributes are implemented
> Don't know what I'm doing wrong.

Hmmm.  I think that's a different error than if you don't have the 
property set at all.  I have never gotten (or tried very hard) the full 
_cocoon_ build running within eclipse.  I have four or five other 
eclipse projects where ant works fine with that property set.  I'll dig 
in a little more.  If you get rid of the property do you get the error 
about the compiler (I forget what it says)?

The error you mention above does look familiar and I'm suspicious it has 
to do with ant revision level.  IIRC eclipse comes with a lower version 
than Cocoon and we may need it - possibly for the custom task xpatch 
which is mentioned there.  Any ant gurus know if there's a difference 
between 1.5 (isn't that what eclipse has?) and 1.6 (isn't that what we 
use) which could cause that error?  Sounds like the setXXX() method that 
custom tasks expect for attributes on custom tasks is not set for 
something.  Hmmmm....


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message