cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <>
Subject Re: Cocoon and eclipse
Date Sat, 27 Sep 2003 03:19:58 GMT
Geoff Howard wrote:
> Joerg Heinicke wrote:
>> Geoff Howard wrote:
>>>> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>>> That's the one.  You can also set that property in the project directly.
>> Hello Geoff,
>> I have tried both
>> compiler=org.eclipse.jdt.core.JDTCompilerAdapter
>> in and
>> <target name="properties" if="eclipse.running">
>>   <property name="build.compiler" 
>> value="org.eclipse.jdt.core.JDTCompilerAdapter"/>
>> </target>
>> in build.xml (as described at 
>> Both don't work:
>> compile-core:
>> compile-deprecated:
>>       [xpatch] BUILD FAILED: java.lang.IllegalArgumentException: No 
>> attributes are implemented
>> Don't know what I'm doing wrong.
> Hmmm.  I think that's a different error than if you don't have the 
> property set at all.

There is no difference between having the property set or not.

> I have never gotten (or tried very hard) the full 
> _cocoon_ build running within eclipse.

I simply tried it because of this thread. I didn't expect it to work.

> I have four or five other 
> eclipse projects where ant works fine with that property set.  I'll dig 
> in a little more.  If you get rid of the property do you get the error 
> about the compiler (I forget what it says)?

As mentioned above. Echoing it immediately before the failure returns 
the property value 'modern' set in

> The error you mention above does look familiar and I'm suspicious it has 
> to do with ant revision level.  IIRC eclipse comes with a lower version 
> than Cocoon and we may need it - possibly for the custom task xpatch 
> which is mentioned there.

Only since Antonio's update to 1.5.4, Eclipse comes with 1.5.3 (at least 
my 2.1.1). I have changed the classpath for the Ant task to Cocoon's 
1.5.4 (which is then also mentioned on the Eclipse console: "Building 
with Apache Ant version 1.5.4 compiled on August 12 2003") and added 
D:\cocoon-2.1\tools\anttasks to the classpath for Cocoon's Ant tasks.

> Any ant gurus know if there's a difference 
> between 1.5 (isn't that what eclipse has?) and 1.6 (isn't that what we 
> use) which could cause that error?

We switched back to 1.5.3 some time ago, Antonio updated it to 1.5.4 in 
the last days.

> Sounds like the setXXX() method that 
> custom tasks expect for attributes on custom tasks is not set for 
> something.  Hmmmm....
> Geoff


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message