cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Macke, Sven" <>
Subject Cocoon 2.0.4 on WAS 5.0.1
Date Tue, 16 Sep 2003 09:09:43 GMT
With this mail, I want to describe a problem I have with Cocoon 2.0.4 on WAS
5.0.1 and
also a solution.

I tried to run the Cocoon 2.0.4 sample web application on my WebSphere
Application Server, 
Version 5.0.1. I got a NullPointerException during a setHeader call on a
servlet response
object. People from IBM told me that the implementation of the WAS changed
in version
5.0.1 and that the servlet spec is implemented more strictly. So, the access
to the
servlet response object is limited to one thread, in my case there a two

In my opinion, this is bug in Cocoon. Any comments about that?

I got a solution posted by someone, so I can provide it here:

Modify the configuration of the xslt-processor in the cocoon.xconf file. Set
the incremental-processing
parameter from true to false. This solved my problem.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message