cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: TransletException when using XSP and SourceWriteTransformer
Date Mon, 27 Oct 2003 14:14:48 GMT
Difficult to say, but you seem to have a real error anywhere. Try to leave 
out the one or the other transformation step or replace the serverpages 
generator with the file generator temporarily. The well-formedness seems to 
be ok, but maybe the generated Java code generates incorrect XML.

Joerg

Stephanie Zohner wrote:
> Hi,
> 
> I tried with Xalan instead of XSLTC, this time I got an 
> 
> Exception in ServerPagesGenerator.generate(): java.lang.RuntimeException:
> org.apache.cocoon.ProcessingException: insertFragment: fragment is required.
> 
> Honestly, this message does not help me much. What "Fragment"? Does this
> refer to the SourceWriteTransformer <source:fragment>? But, then, why do I get
> an Exception in the ServerPagaesGenerator and not in the XSL-Engine?
> 
> I also tried with SAXON, with it, I get a DOMException, complaining about an
> "invalid character". However, I can't figure out where. (I have lot's of "/"
> and "\" in the attribute values of my generated xml, but at least the
> Filegenerator does not complain about them, so the XML seems to be well-formed)
> 
> So three different XSLT Parsers 3 different error messages, but still I
> can't locate the problem. 
> 
> Can it be that the XML-Structure, the XSP generates is in a way too complex
> for the SourceWriteTransformer?
> 
> Thanks,
> 
> Stephanie
> 
> 
>>From: Stephanie Zohner
>>
>>
>>>Hi,
>>>
>>>I need your help.
>>>
>>>I get a Translet-Exception due to an EmptyStackException when 
>>>I try to apply the SourceWriteTransformer on a XSP generated 
>>>XML-Stream.
>>>
>>>Here is my sitemap fragment:
>>>
>>><map:match pattern="config">
>>>   <map:generate type="serverpages" src="config-form2.xsp"/>
>>>   <map:transform type="xslt" src="save.xsl"/>
>>>   <map:transform type="write-source"/>
>>>   <map:serialize type="xml"/>
>>></map:match>
>>>
>>>However when I save the output of the xsp logicsheet 
>>>manuelly, and apply the SourceWriteTrasformer on it, 
>>>everything works fine.
>>>
>>>Does anybody have an idea, what I did wrong?
>>
>>Only a guess, but maybe it's a problem with XSLTC. Please try Xalan as
>>XSLT-Transformer.
>>
>>Reinhard
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>>For additional commands, e-mail: users-help@cocoon.apache.org
>>
> 
> 

-- 
System Development
VIRBUS AG
Fon  +49(0)341-979-7419
Fax  +49(0)341-979-7409
joerg.heinicke@virbus.de
www.virbus.de


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message