cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Liu" <andy-coc...@dslextreme.com>
Subject Re: Error running 2.1.3 app in 2.1.4
Date Thu, 26 Feb 2004 08:54:55 GMT
Hi Tony,

I just migrated my 2.1.3 app to 2.1.4. I faced the same problem that you
have.  The solution is

sitemap.xmap [2.1.3]
<map:components>
    <map:generators default="file">
      <map:generator name="jxforms"
src="org.apache.cocoon.generation.JXFormsGenerator"
logger="jxforms.sitemap.generator"/>
    </map:generators>
    <map:flow-interpreters default="javascript"/>
    <map:serializers default="html"/>
    <map:matchers default="wildcard"/>
  </map:components>

sitemap.xmap [2.1.4]
<map:components>
    <map:generators default="file">
      <map:generator name="jxforms"
src="org.apache.cocoon.generation.JXFormsGenerator"
logger="jxforms.sitemap.generator"/>
    </map:generators>

<!--  Removed the below line
    <map:flow-interpreters default="javascript"/>
-->

    <map:serializers default="html"/>
    <map:matchers default="wildcard"/>
  </map:components>

  <!-- Remember to have following lines -->
  <map:flow language="javascript">
     <map:script src="flow/myflow.js"/>
  </map:flow>


You application should be just like before.

I also found that the petstore and jxform also do not work in 2.1.4
because of the same problem.  I hope we will remove the line for the
coming new version of cocoon.

PS. I am a new cocoon user. I have not yet figure out how to submit bug to
bugilla and make change the source code by myself.  I hope I will learn to
do that in the near future.

Best Regards,
-Andy

Tony Edwards wrote:
> Folks,
> I'm still interested to hear if I can generate woody forms on the fly -
> but it isn't really a show stopper at this stage (I'm quite happy to
> just insert a configuration step that generates the necessary forms and
> move these to a 'production' area).
>
> In the meantime, I just downloaded the latest 2.1.4 build and got
> everything running. I then copied over a 2.1.3 working application and
> got this error:
> "org.apache.cocoon.ProcessingException: Failed to load sitemap from
> file:/C:/cocoon-2.1.4/build/webapp/SGSAssets/SGSAssets.xmap:
> org.apache.avalon.framework.configuration.ConfigurationException: No
> languages defined!"
> What has changed from 2.1.3 to 2.1.4???
>
> As always, thanks for you help!
>
> Tony
>
>>
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message