cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: WebServiceProxyGenerator error
Date Wed, 04 Feb 2004 00:38:47 GMT
I didn't expect any changes on the behaviour as there was no fix on this 
particular problem. But you seem to refer to a patch which was maybe 
missed on the list and not applied into the CVS.

BTW, how does ** or {1} in the map:generate look like?

Joerg

On 03.02.2004 13:01, Anna Afonchenko wrote:

>   I downloaded the newest version (from December) from CVS,
>   but I still get the java.lang.IllegalArgumentException: host must not be
> null
>   Is there something else I'm missing here?
> 
>   Thank you very much for help
> 
>   ----- Original Message ----- 
>   From: "Joerg Heinicke" <joerg.heinicke@gmx.de>
> 
>   > > Hi all.
>   > > I am trying to use the WebServiceProxyGenerator in order to process
> the result
>   > > of external form submit through my pipeline.
>   > > I've got one of the latest cocoon releases.
>   > > Here is what I write in the sitemap:
>   > >
>   > > <map:generator name="wsproxy" logger="sitemap.generator.wsproxy"
> src="org.apache.cocoon.generation.WebServiceProxyGenerator"/>
>   > > <map:match pattern="testForm/**">
>   > >
>   > > <map:generate type="wsproxy" src="{1}">
>   > > <map:parameter name="wsproxy-method" value="post"/>
>   > > </map:generate>
>   > > <map:serialize type="html"/>
>   > > </map:match>
>   > >
>   > > When I try to run it, I get a "host is null" error.
>   > > I found few posts about this problem, but the patch suggested
>   > > there is from July, and my version of WebServiceProxyGenerator
>   > > is from September, so I assume that this patch should be there?
>   >
>   > Maybe you tell us which patch you refer to. See
>   >
> http://cvs.apache.org/viewcvs.cgi/cocoon-2.1/src/blocks/proxy/java/org/apache/cocoon/generation/WebServiceProxyGenerator.java
>   > for changes on the wsproxy generator.
>   >
>   > > So I don't know if my problem is because I don't have this patch, or
> because of
>   > > some other thing.
>   > >
>   > > Attached is my version of WebServiceProxyGenerator.java
>   >
>   > It's exactly version 1.4 of the java file in CVS, in the meantime we are
>   > at 1.6.
>   >
>   > Joerg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message