cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephane Delort" <Stephane.Del...@edag.de>
Subject [Cforms] fd:action in struc, class or union special issue
Date Fri, 13 Aug 2004 07:34:29 GMT
Hello,

I have a form which uses structs, classe and unions.
Then, I tried to have a fd:action in one of them.

First I tried with union:


definition file :

 <fd:union id="start" case="type" default="widgetClass">
      <fd:datatype base="string"/>
      <fd:widgets>
        <fd:struct id="widgetClass">     // in a struct because it will be with other
widgets (but with none for the test)
         <fd:widgets>
             <fd:action  id="seeChildren"  action-command="seeChildren">
                      <fd:label>See related childs</fd:label>
                      <fd:on-action>
                        <javascript>
                             java.lang.System.err.println("pirouette cacahuete 2 ");
                        </javascript>
                     </fd:on-action>
                </fd:action>
      </...>

template file :

<ft:union id="start">
        <ft:case id="widgetClass">
          <hr />
          <ft:struct id="widgetClass">
            <ft:widget id="seeChildren"/>
          </ft:struct>
          <hr />
        </ft:case>
</...>


on the result page (html) I have the correct button but once clicked I go
through an beautiful white page [1] and the text is not printed.
I have the same result when I put it in a struct or a class.

I first though I had a problem with my button but this one works OK  if I
do not put it into a class, struct or union (the page is redisplayed and
the text is printed out )

I looked at error.log,  flow.log and forms.log in
$cocoon/build/webapp/WEB-INF/logs  but these are empty (and others do not
have anything relevant).

I googled and RTFM but did not noticed any special issue about fd:action in
union, struct or class


Any help greatly apreciated  (actually, which help is not ? ;-)  ),
Stephane


[1] : html code of the white page

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message