cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Björn Voigt <bvo...@hs-harz.de>
Subject Re: form-enconding in web.xml doesn't take effect
Date Mon, 09 Aug 2004 07:43:59 GMT
Marc Portier wrote:
> have you changed only form-encoding to utf-8 ?
> the container-encoding in web.xml should remain default...
> 
> regards,
> -marc=
> 
> 
> 
> Björn Voigt wrote:
> 
>> Hello list,
>>
>> I run a cocoon (2.1.5) site with UTF-8 encoding and use the lucene 
>> search generator.
>> The site is correctly serialized with UTF-8. If I fill the search form 
>> with a query string
>> containig german umlauts, the parameter is also correctly encoded.
>>
>> (I run it in JETTY)
>>
>> I have changed the form-encoding in web.xml to UTF-8, but it seems, 
>> that the request
>> paramters still be ISO-8859 decoded. I have tested it with
>>
>>             Request request = ObjectModelHelper.getRequest(objectModel);
>>             //Encode the wrong decoded string back to original
>>             String wert = 
>> URLEncoder.encode(request.getParameter("queryString"),"ISO-8859-1");
>>             //Decode it with UTF-8
>>             wert = URLDecoder.decode(wert,"UTF-8");
>>             System.out.println(wert);
>>
>> and got the right
>>
>>
>> What could be happen?
>>
>> regards
>>
>> Björn
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
> 
yes I have, this was the first, I  also read the encoding wiki, but it
is still ISO-8859 decoded.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message