cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakob Fix <jakob....@gmail.com>
Subject Re: Existing XSP "not found" by Cocoon (only on Linux)
Date Tue, 15 Nov 2005 11:40:45 GMT
Lars,

thanks for your reply.  It's been quite some time, but I still have
the problem I described originally.  The most astonishing is that out
of two XSP pages, one ("search.xsp") is compiled correctly, while the
other one ("highlight.xsp") is not.

Although we had some problems with case sensitivity when moving from
Windows to Linux, this was unrelated to the XSP pages (some javascript
files were named using CamelCase, but called using simple
Capitalcase).

The temporary directory for Cocoon's compiled XSP pages on the Linux
machine is:
/tmp/Jetty__8080__/cocoon-files/org/webapp/__/search/

BTW, where is this temporary directory configured?

Currently, it contains only the search_xsp.class and search_xsp.java
files.  I tried to manually copy the two corresponding
highlight_xsp.(java,class) files from the Windows to this directory,
however they disappeared almost instantly when trying to access the
XSP page.

The two XSP pages are quite similar.  I can attach them if this would
help to analyse the problem.


On 04/11/05, Lars Huttar <lars_huttar@sil.org> wrote:
> Jakob Fix wrote:
>
> >Hello,
> >
> >I'm having a weird problem porting a web application to Linux.  The
> >application itself consists of Java 1.5 / Jetty / Cocoon 2.1.7 / Exist
> >XML database.  It was developped in a Windows environment, but now we
> >want to deploy it on a Linux server.  Almost everything went very
> >well, it's Java after all.
> >
> >However, one persisting problem I have is this:  Cocoon appears to not
> >be able to compile one of the two XSP pages saying that it can't be found,
> >although it absolutely positively exists at the location indicated
> >(see attached core.log and access.log extracts).
> >
> >I've added the tools.jar to my jre's lib/ directory because I read on
> >the cocoon website its absence may not allow to compile certain
> >jsp/xsp pages.  However, I have two XSP pages of which one functions
> >correctly while the other one cannot apparently be found and thus
> >compiled.
> >
> >I've tested this on another Linux server (also Debian) with the same results.
> >
> >I'm not really sure what other information I should provide (is the
> >actual XSP code interesting?).
> >
> >This problem really puzzles me.  Any help is greatly appreciated.
> >
[snip]
> >
> I haven't looked at your details or log, but the problem sounds like one
> we had, based on case sensitivity issues:
> The compiled XSP page exists but has the wrong casing; the piece of
> Cocoon thath would compile missing files case-insensitively recognizes
> its presence and therefore doesn't recompile it, but the piece of Cocoon
> that would execute the compile file case-sensitively declares it's not
> there. (The casing of the compiled file was wrong because we had changed
> the casing of the xsp file after having it compiled once; Cocoon was
> never able to handle that.)
> This problem could be affected by having developed on Windows (which has
> more case insensitivity) and run on Linux.
>
> We solved the problem under Tomcat by deleting the work/ folder, forcing
> a recompile of all XSP pages. Sounds like you would do this by deleting
>
> /var/www/dynaprism/lib/exist/tools/jetty/work
>
>
> If that doesn't help, let us know...

I'm doing it right now :-)  Thanks.

--
cheers,
Jakob.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message