cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew <andrewm...@gmail.com>
Subject Re: Xhtml and Ajax...no go!!
Date Thu, 27 Jul 2006 20:28:51 GMT
Hi Mark,
the problemo is this:

1. You are all set up for ajax
2. Your page loads through your pipe with following:

				<map:select type="ajax-request">
				  <map:when test="true">
				    <map:serialize type="xml"/>
				  </map:when>
				  <map:otherwise>
				    <map:serialize type="xhtml"/>
				  </map:otherwise>
				</map:select>

Notice that serialize type="xhtml".

3. Page breaks!!
4. Problem is caused by the javascript code immediately following the
<form> tag:
<script>cocoon.form.ajax = true;</script>
5. If you change script after form tag to read <script src="" /> where
your src is the one line of javascript,
you get an error message saying 'cocoon undefined'.
6. Switch serialize type back to type="html" and page loads ok using
either inline or include script tags!

Try it and see...Any ideas for this one would be great!!

regards

Andrew




On 27/07/06, Mark Lundquist <ml@wrinkledog.com> wrote:
>
>
> On Jul 27, 2006, at 9:20 AM, Andrew wrote:
>
> > But it is not the pipe which is causing the problem, it is the
> > javascript syntax directly after the initial form tag in the xhtml
> > page.
>
> So, what _is_ the actual problem here?... Going back to the first post,
> it just says that it "breaks the page"... sorry if I'm missing
> something.. ;)
> —ml—
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>

Mime
View raw message