cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fawzib Rojas <f_ro...@spectron-msim.com>
Subject Problem with custom StreamGenerator
Date Tue, 03 Oct 2006 13:55:46 GMT
I have a custom StreamGenerator and it is giving me some problems. I 
have used it with a custom application I've made and it works. I send a 
POST with my information and I can use the posted info in my custom 
generator. My problem is that when I use an actual FORM with a post 
message it fails.

This is the HTTP message from my app:

POST /servers HTTP/1.0
Connection: keep-alive
Content-Type: text/xml
Content-Length: 99
Host: 192.168.10.125
Accept: text/html, */*
Accept-Encoding: identity
User-Agent: Mozilla/3.0 (compatible; Indy Library)

<post_data_removed>

This is what Firefox sends when I submit the form:

POST /msim/SamplePackage.pdf HTTP/1.1
Host: www.spectron-msim.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) 
Gecko/20060909 Firefox/1.5.0.7
Accept: 
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: <removed>
Authorization: <removed>
Content-Type: application/x-www-form-urlencoded
Content-Length: 57

<post_data_removed>


I think that since the 'Content Type' is 
'application/x-www-form-urlencoded' Cocoon is trying to process it 
before my generator deals with it. I tried adding ENCTYPE='text/xml' to 
my form but it seems Firefox and IE ignore it because I always get 
'application/x-www-form-urlencoded'. Can anyone give me a hand?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message