cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Cannot get JSPReader/JSPGenerator to work
Date Fri, 06 Oct 2006 06:43:09 GMT
On 06.10.2006 05:38, Paritosh Patel wrote:

> The JSP engine is Jasper. Switching this to the Tomcat version is the
> next step. I will keep you posted (if you want).

Hi Paritosh,

I cared a bit about the JSP block at least being working in the last 
years, but I have never used it in a project. So the knowledge is still 
bit limited, but I might know some limitations of Cocoon's JSPEngine 
itself. For example there are probably no forwards and includes possible.

At the end the problem is that JSPs are not well-supported running 
inside Cocoon and we have never recommended using JSPs. But this will 
change in Cocoon 2.2 as it will work more on the servlet level. It's no 
longer a Cocoon webapp started by the servlet container, handling a JSP 
request delegating to a JSPEngine which at the end calls again the 
servlet container - with problems setting up a correct environment for 
handling them. Cocoon will be able to integrate with other servlets much 
better and so also with JSPs. This will even make the JSP block superfluous.

Jörg

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message