cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lally Singh" <>
Subject Re: Block version problems?
Date Thu, 05 Apr 2007 05:05:43 GMT
On 4/4/07, Lally Singh <> wrote:
> On 3/29/07, Lally Singh <> wrote:
> > On 3/29/07, Grzegorz Kossakowski <> wrote:
> > > Also please show me pom.xml of your application. If it will not help me
> > > with tracking the problem you'll have to mvn -X output and Cocoon's logs
> > > but let's try simpler options first.
> I've tracked it down some.  I updated my applicationContext.xml to
> include <avalon:bridge />, and that line invokes the error.  What I
> don't get is
> that I have ~/.m2/repository/org/apache/avalon/framework/avalon-framework-impl/4.3.1/avalon-framework-impl-4.3.1.jar
> in the Classpath Maven lists when I run the app, and I verified that
> the required method is in fact in that version of the avalon framework
> impl.

Ok, Solved.  A dependency on commons-logging caused a dep on
avalon-framework 4.1.3, which was eventually replaced by
avalon-framework-impl and avalon-framework-api.  As the artifactIds
changed, I guess maven couldn't have known that one replaced the
other. An <exclusions> tag fixed that right up.

Thanks for your help Grzegorz!!!

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message