cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: Javaflow - major memory issue
Date Thu, 03 Apr 2008 21:04:19 GMT
footh <footh <at> yahoo.com> writes:

> Ok, I applied all the changes in order.  Since some changes affect the same
> class, I'm assuming the latter change contains any changes from a previous
> revision.

I don't know how exactly you mean this, but one *change* does definitely not
include the former changes since it is always a diff against the latest
revision. If I were you I would just grab the latest revisions of the mentioned
files. Those ones also have all the former changes. There should be no
incompatibility introduced between 2.1.10 and latest code in the 2.1 SVN branch.

> I'm getting this error when building:
> 
> \src\java\org\apache\cocoon\components
> \flow\ContinuationsManagerImpl.java:538: clone() has protected access in
> java.lang.Object
>             clonedRootWebContinuations.add(rootContinuation.clone());
> 
> Did I mess up applying the changes?  Have you successfully built the revised
> version?

That's more or less my fault. I made another commit where I did not separate
clearly the issues and part of the fixes you are actually interested in got into
that commit. It's http://svn.apache.org/viewvc?rev=643294&view=rev, but what you
actually only need from this commit are part of the changes to WebContinuation:
add Cloneable to its implements list, get the two methods toString() and
clone(). Leave the rest just as it is if you are not interested in Flowscript.

Hope this helps,

Joerg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message