cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Enrico Ballarin Dolfin <>
Subject Deployment of cocoon 2.2 application on production tomcat 5.5 fails
Date Wed, 03 Sep 2008 08:52:00 GMT

in my development environment (openSUSE 10.3) I could develop a  
cocoon 2.2 application using maven, run it using Jetty and also  
deploy the generated WAR file on the local tomcat 5.5 and everything  
worked well.

Trying to deploy the same WAR on a tomcat 5.5 in production, the WAR  
file get expanded automatically in the webapps directory, but when I  
restart tomcat to let recognize the new application, I'm getting  
following error:

Logfile: catalina_2008-09-02.log

Sep 2, 2008 5:17:49 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive getReceivers-1.0.0.war
log4j:WARN No appenders could be found for logger  
log4j:WARN Please initialize the log4j system properly.
Sep 2, 2008 5:17:52 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Sep 2, 2008 5:17:52 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/getReceivers-1.0.0] startup failed due to previous  

- I'm missing something in the production tomcat 5.5 environment ?
   I thougth that everythng needed should be contained in the WAR  

- Do I need to install maven also in the production environment, to  
be able to run there the WAR application on tomcat ?

I have also tried to increase the debug level to get more information  
about the "listenerStart" problem in the log file, but without success.

Thanks in advance for your help!


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message