cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Müller <>
Subject AW: AW: [C2.2] Display Upload Progress
Date Tue, 20 Jan 2009 08:37:40 GMT
Hi David,
first, a big THANKS for helping me and at the same time sorry that i destroyed your sample
webapp. i had the same result (warning and error messages) like you and finally some working
what i didn't understand so far is:
which instance decides which version of an artifact is the latest? why does maven try to download
e.g. cocoon-core:2.2.1 when it's not available/released?

regards, matthias

----- Ursprüngliche Mail ----
Von: David Legg <>
Gesendet: Montag, den 19. Januar 2009, 18:00:02 Uhr
Betreff: Re: AW: [C2.2] Display Upload Progress

Hi Matthias,

> Hi i compiled all the samples as you described. but when i type "mvn -P allblocks jetty:run"
in core/cocoon-webapp i still have the problem with the missing artifacts. don't you have
problem that maven wants to download artifacts that doesn't exist in the specified remote

To check what's going on I've rebuilt Cocoon from the latest subversion copy.

I deleted my maven repository (to ensure the build process starts from scratch).
I updated my subversion copy of Cocoon.
I ran 'mvn clean'

Here I ran into a few error messages.  Not sure why it would need a plugin in order to cleanup
a few files: -

from the specified remote repositories:
   central (


I ignored this and then executed the main build command: -

mvn install -P allblocks

After a very long time and lots of messages and tests it built successfully: -

[INFO] ------------------------------------------------------------------------
[INFO] Total time: 36 minutes 54 seconds
[INFO] Finished at: Mon Jan 19 16:00:33 GMT 2009
[INFO] Final Memory: 134M/240M
[INFO] ------------------------------------------------------------------------


Now for the moment of truth... to run the webapp!

cd core\cocoon-webapp
mvn jetty:run

Uh oh!  It runs jetty but only after spewing out loads of errors about bean configuration.
 I've attached the messages to this email.

If I persevere and try accessing the sample webapp it not unexpectedly returns error 503 (Service

So... *I guess the answer is the subversion trunk is currently broken*... which is unfortunate
for me because now I cannot run the examples either :-(

I was using Maven version 2.0.9 which is the bare minimum you need to build Cocoon.  As for
accessing those other repositories I had no problem (even though I think it is probably time
to remove the dependency on some things from Grek's personal site!).  Actually, if you look
in the 'parent' folder you will see these other repositories listed in the pom.xml: -

     <name>Maven central repository</name>
       <!-- only look for jars here when they are not present locally -->
   <!-- This is temporary repository -->

David Legg

To unsubscribe, e-mail:
For additional commands, e-mail:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message